2001 Pontiac Grand Prix wtf! What is wrong?

Tiny
JWERK24
  • MEMBER
  • 2001 PONTIAC GRAND PRIX
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 120,000 MILES
Ok well here I go, it all started about a month ago, my car quit running so I changed out the battery, and altenator, and got it running, then the water pump went, I replaced it, now the car is doin something again, its a 2001 pontiac grand prix se, with 120000 miles on it, oil changed every 3500 miles, and fluids changed just last week, a full system flush new fluids, and a new trans on 1-20-2009, so to the problem, I went to get in my car, I turned the key to start it, and it turned over ran for 5 seconds, and shut off, I tried again, same, I tired the remote start, same thing, I looked at the fuses, all r intact, the starter has been making a crunching noise, so it is about to go, but its, not the problem, could it be the fuel pump, or something electrical? Any help is needed and well appreicated
Do you
have the same problem?
Yes
No
Monday, March 9th, 2009 AT 6:18 PM

18 Replies

Tiny
BLUELIGHTNIN6
  • EXPERT
You will need to check for spark and fuel. Sounds like a fuel problem though. Make sure plugs are getting a healthy bright blue spark to them. Check fuel pressure at rail with a gauge. Can you hear the fuel pump kick in for 2-4 seconds when you first turn key without cranking?

Thanks for using 2CarPros. Com!
Was this
answer
helpful?
Yes
No
Monday, March 9th, 2009 AT 6:21 PM
Tiny
JWERK24
  • MEMBER
It sounds as if the fuel is recieved just cranks over for a few seconds and shut right off
Was this
answer
helpful?
Yes
No
Monday, March 9th, 2009 AT 6:24 PM
Tiny
BLUELIGHTNIN6
  • EXPERT
Since it is starting up and shutting right back off you need to inspect your fuel pump relay.
Was this
answer
helpful?
Yes
No
Monday, March 9th, 2009 AT 8:20 PM
Tiny
JWERK24
  • MEMBER
The relay was changed, not the issue, could it be a clog in the fuel filter?
Was this
answer
helpful?
Yes
No
Wednesday, March 11th, 2009 AT 2:42 PM
Tiny
BLUELIGHTNIN6
  • EXPERT
Very doubtful. Clogged filter would only restrict the fuel flow. Since it is starting up and dieing there is fuel getting through the lines. The pump is shutting off for some reason so either the pump is faulty, the wiring is faulty, or there is an issue with the ignition. Is there any anti-theft light on in dash that shouldn't be on?
Was this
answer
helpful?
Yes
No
Wednesday, March 11th, 2009 AT 4:49 PM
Tiny
JWERK24
  • MEMBER
I just replaced the relay and the fuel filter, and it still is happening, the vehicle does have an anti theft system, but is bypassed by the viper remote start and alarm, so I just unplugged them and it is not the problem, I installed the system myself, since I work at an audio store, so what else could it be.
Was this
answer
helpful?
Yes
No
Thursday, March 12th, 2009 AT 6:02 PM
Tiny
BLUELIGHTNIN6
  • EXPERT
Okay. I suggest having your catalytic converter flow tested. Suspect that it is clogged up.
Was this
answer
helpful?
Yes
No
Thursday, March 12th, 2009 AT 8:18 PM
Tiny
JWERK24
  • MEMBER
I just replaced the converter do I burst a hole in it, plus im puttin a gtp exhaust on soon, so thought I change it, do u think it could be electronic, (wiring harness)? Should I just ship it to a dealer to check it out?
Was this
answer
helpful?
Yes
No
Friday, March 13th, 2009 AT 11:54 PM
Tiny
BLUELIGHTNIN6
  • EXPERT
It could be electrical. Its hard to diagnose issues like this over the PC without actually being able to see, smell etc.. I think you may be better off just letting the dealer run a diagnostic on it to save you a lot of time and headache in the long run.
Was this
answer
helpful?
Yes
No
Saturday, March 14th, 2009 AT 12:01 AM
Tiny
JWERK24
  • MEMBER
Thanks, rite now the caar isnt really my big issue, I just do want it running, but dealers, were my last resort(expensive) and yeah it would save me the headache, thank u, yeah I wish I took mechanics in school instead of body tech
Was this
answer
helpful?
Yes
No
Saturday, March 14th, 2009 AT 12:03 AM
Tiny
JWERK24
  • MEMBER
Thanks for all ur help, I know it is hard to do alot without knowing what the hell is wrong with it to begin with, so I guess, I will have to resolve to takin it to the dealer, I really hope its something simple, maybe I or we both over looked, but again, thanks for u help
Was this
answer
helpful?
Yes
No
Saturday, March 14th, 2009 AT 11:12 AM
Tiny
BLUELIGHTNIN6
  • EXPERT
You're welcome. If you would please post what the diagnosis is so we can better help people in the future with similar issues.

Thanks for using 2CarPros. Com!
Was this
answer
helpful?
Yes
No
Saturday, March 14th, 2009 AT 1:45 PM
Tiny
JWERK24
  • MEMBER
No problem be glad to help fellow car people, escpecially fellow pontiac lovers
Was this
answer
helpful?
Yes
No
Sunday, March 15th, 2009 AT 9:08 PM
Tiny
CCGPGTP
  • MEMBER
As long as you can hear the fuel pump kick on when turning the cars electrical system on, I wouldn't worry too much about it being something to do with that unless you have clogged injectors. However there could be a few problems with it. 1. It could have something to do with your alarm system. Since you are not using the factory system there could be a problem with the wiring in the new system. 2. It could be the Idle Air Control. Try starting the car with your foot on the throttle to create a false idle. If this keeps your car running I suggest taking it to a shop to have that inspected. It may need cleaned or replaced.
Was this
answer
helpful?
Yes
No
Monday, March 23rd, 2009 AT 12:18 PM
Tiny
JWERK24
  • MEMBER
Thanks, could it be a vacuum goin bad?
Was this
answer
helpful?
Yes
No
Monday, March 23rd, 2009 AT 6:09 PM
Tiny
CCGPGTP
  • MEMBER
Yes it could be a vacuum, but first try starting the car with your foot just lightly pressed down on the gas pedal. This will open up the throttle and if it is your IAC then the car should continue to run until you have let off of the throttle at which time it will stall. If this occurs, just do like I said and take it in to have the part inspected. They aren't overly expensive for this car. About a couple hundred for parts and labor.I had this same problem happen with me 00' GTP and it was in fact my IAC. Good luck!
Was this
answer
helpful?
Yes
No
Tuesday, March 24th, 2009 AT 8:41 AM
Tiny
JWERK24
  • MEMBER
I DONT KNOW WHAT IT WAS, BUT I LEFT LIGHTS AND ALARM ON SO IT COULD DRAIN BATTERY, AFTER IT DID, I CHARGED BATTERY TO FULL CHARGE AND THE CAR STAYED RUNNING, I HAVE TO BELIEVE ITS THE COMPUTER ECm, OR ECu, SO ITS FINE

THANKS FOR THE HELP

JUSTIN
Was this
answer
helpful?
Yes
No
Sunday, March 29th, 2009 AT 10:51 PM
Tiny
CCGPGTP
  • MEMBER
No problem! Glad you were able to figure out the problem! Might need to have your computer reprogrammed in the future!
Was this
answer
helpful?
Yes
No
Monday, March 30th, 2009 AT 10:24 AM

Please login or register to post a reply.

Recommended Guides