Noisy cold start, check engine light on

Tiny
VIVEKHB
  • MEMBER
  • 2003 MERCEDES BENZ C230
  • 1.8L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 230,000 MILES
My car on cold start, engine makes noise for a minute or so and then the noise fades off.I always have a CEL.
I also noticed that on signals the car RPMs rise as I move.
I plan on changing the exhaust manifold gasket.
Your valuable opinion is requested, as I have never changed the gasket. What more have I to remove?
Thanks in advance.
Do you
have the same problem?
Yes
No
Friday, July 30th, 2021 AT 7:25 AM

35 Replies

Tiny
SQM
  • EXPERT
Hello,

Do you know what are the trouble codes (CEL)?
This might point you to the right direction.
Also can you upload a video of the noise?
Usually exhaust manifold leaking noise will be present for several minutes until the engine is warm enough to expand the manifold and stop the leak.
Is there any smoke coming out of the exhaust?

https://www.2carpros.com/articles/how-exhaust-systems-work

I have attached the exhaust manifold gasket replacement process for your reference.

Please let me know little more info.

Thank you.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 8:10 AM
Tiny
VIVEKHB
  • MEMBER
Hi, thanks for your response. There is no smoke coming out of the exhaust, but as you said the noise is only for few minutes until the engine warms up.
Code P0410 -Sec. Air injection fault, air flow is too low.
Am I on the right tract?Relying on your expert advice. Thanks once again.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 9:26 AM
Tiny
SQM
  • EXPERT
Well, when a secondary air injection pump becomes faulty it can make noise as well on startup, the will go away after a little while.
Many times you can simply clean out the pump (if it has visible gunk inside of it).
I would suggest you first take care of the air pump, before tackling exhaust manifold gasket.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 9:41 AM
Tiny
VIVEKHB
  • MEMBER
My car is supercharged hence it does not have the air injection pump/smog pump, please correct me if I am wrong.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 11:10 AM
Tiny
SQM
  • EXPERT
Correct. Because the C230 Kompressor is supercharged there is not another air pump.
There is a line that is diverted from the intake just before the throttle body. (Look below)
That goes to a vacuum actuator, which acts as the pump. Which can still get gunky inside and cause the CEL.
Was this
answer
helpful?
Yes
No
+1
Friday, July 30th, 2021 AT 11:39 AM
Tiny
VIVEKHB
  • MEMBER
Sorry Sir, but I can't see the vacuum actuator valve but I can see the throttle body. Please your support is highly appreciated. Waiting for your reply.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 12:26 PM
Tiny
SQM
  • EXPERT
You will have to remove the plastic covers in order to access.
Can you upload picture of under hood?
I believe the picture I sent you is for a 02, I think the 03 is little different.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 1:34 PM
Tiny
VIVEKHB
  • MEMBER
Sir, thanks for the reply. To be honest I don't see the Vacuum actuator. I took some photos that are posted on youtube that pertain to my model. Please direct me on the photos as to which line that gets gunky inside that causes CEL, that I have to disconnect and replace or can be cleaned. Thanks.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 2:06 PM
Tiny
SQM
  • EXPERT
This should be that valve (see below).
It typically gets gunk built-up inside the valve. When you take the hose off, you can usually see the inside. This can be cleaned by parts cleaner, just be careful not to use too much cleaner inside.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 2:11 PM
Tiny
VIVEKHB
  • MEMBER
Thanks a lot, Sir.I will clean and let you know the outcome.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 2:25 PM
Tiny
SQM
  • EXPERT
You're welcome.
Let me know if you have any other questions.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 2:28 PM
Tiny
VIVEKHB
  • MEMBER
Sorry Sir, but I can't see the vacuum actuator valve. Please the picture so sent me I cannot get it on my car.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 5:42 PM
Tiny
SQM
  • EXPERT
Look at the picture below. Does your engine by looks like this? Circled in red.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 7:33 PM
Tiny
VIVEKHB
  • MEMBER
Yes, it does look exactly the same.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 7:34 PM
Tiny
SQM
  • EXPERT
That should be the valve. Let me know the outcome after you clean it out.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2021 AT 7:36 PM
Tiny
VIVEKHB
  • MEMBER
Sir, I cleaned the valve, (was not that gunky inside ), erased the code.
The noise on cold start has vanished and after 13 km drive, the CEL has not come back, seems -mission accomplished.
I want to clarify one thing - the vacuum actuator valve is also called EGR valve?Please confirm.
And thanks once again for your valuable advice.I will be in touch with you on this update in a couple of days.
Have a blessed weekend, bye.
Was this
answer
helpful?
Yes
No
Saturday, July 31st, 2021 AT 12:51 PM
Tiny
SQM
  • EXPERT
EGR : exhaust gas recirculation valve is not same the vacuum actuator.
That actuator works from the intake side. The EGR works on the exhaust side.
Glad it is working now.
Happy to help.
Was this
answer
helpful?
Yes
No
Saturday, July 31st, 2021 AT 8:32 PM
Tiny
VIVEKHB
  • MEMBER
Hi Sir, you state the vacuum actuator works from the intake side, so the vacuum actuator (you happen to round in the diagram) I happen to clean is on the exhaust side. On the intake side I don't see any vacuum actuator.
Now, I am confused because the CEL has come up again as I was driving.
Waiting to hear from you.
Was this
answer
helpful?
Yes
No
Sunday, August 1st, 2021 AT 2:23 PM
Tiny
SQM
  • EXPERT
Is the vehicle giving you the same CEL code?
Would it be possible to upload few pictures of the engine area of your car?
Some reason I am getting conflicting information on the 2003 C230.
As that was a refresh year.
Was this
answer
helpful?
Yes
No
Sunday, August 1st, 2021 AT 2:44 PM
Tiny
VIVEKHB
  • MEMBER
Sir, I got the same code P0410.
Also here are the pictures of the engine bay, thanks once again.
Was this
answer
helpful?
Yes
No
Sunday, August 1st, 2021 AT 4:09 PM

Please login or register to post a reply.

Sponsored links