No spark no fuel

Tiny
LYLE GIBSON
  • MEMBER
  • 2006 SUZUKI RENO
  • 2.0L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 94,000 MILES
Ran good, drove in the garage it shut off. Tried restarting started then immediately stalled. Now it cranks but no sound from fuel pump, no spark at coils or wires. Replaced crank sensor and cam sensor checked wiring and replaced battery cable ends. Checked all fuses tried Solus scan tool had crank sensor code replaced crank and cam sensor cleared the code now no codes are coming up. Have twelve volts going to ECM, but I checked the connector to the crank sensor and there is no voltage at all coming from the connector cranking or no cranking does matter no voltage. Checked wiring and it looked good and ideas and is it the ECM? Also, checked ECM fuse with tester have power there checked ignition coil fuse, nothing fuse is good same with fuel fuse no power but fuse is good.
Do you
have the same problem?
Yes
No
Sunday, December 10th, 2017 AT 1:32 AM

15 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked the ASD relay under the hood in the relay box?
Was this
answer
helpful?
Yes
No
+1
Monday, December 11th, 2017 AT 5:44 PM
Tiny
LYLE GIBSON
  • MEMBER
No, will do that today and let you know the findings.
Was this
answer
helpful?
Yes
No
Tuesday, December 12th, 2017 AT 11:02 AM
Tiny
LYLE GIBSON
  • MEMBER
Not finding that relay under the hood here is a picture of the relay box. But, I do want to add that when cranking the engine the I get hit and miss power to the fuel pump as well as spark. Car will start with starting fluid but shuts off immediately.
Was this
answer
helpful?
Yes
No
Tuesday, December 12th, 2017 AT 11:12 AM
Tiny
KEN
  • ADMIN
Did you upload a picture? I think what JACOBANDNICKOLAS ment was to check the MAIN relay becasue it runs the system. Here are some engine wiring and fuse panel diagrams to help you see whats going on with a couple of guides (below)

https://www.2carpros.com/articles/how-to-check-a-car-fuse

and

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Check out the diagrams (Below)

Let us know what happens and please upload pictures or videos of the problem.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Sunday, December 17th, 2017 AT 3:07 PM
Tiny
LYLE GIBSON
  • MEMBER
Checked all fuses and relays everything is checking out good.
Was this
answer
helpful?
Yes
No
Sunday, December 17th, 2017 AT 9:38 PM
Tiny
KEN
  • ADMIN
Im sorry but I would like to look at the fuse panel to see if we have the right car? Can you upload a picture?
Was this
answer
helpful?
Yes
No
Monday, December 18th, 2017 AT 11:30 AM
Tiny
BEST CHOICE AUTOSALES
  • MEMBER
Sent
Was this
answer
helpful?
Yes
No
Monday, December 18th, 2017 AT 9:51 PM
Tiny
KEN
  • ADMIN
Sorry I was talking about the actual panel picture using your phone? I have that diagrams above ;)
Was this
answer
helpful?
Yes
No
Tuesday, December 19th, 2017 AT 12:59 PM
Tiny
LYLE GIBSON
  • MEMBER
Here is the pic I have of the lid of the panel hope this helps
Was this
answer
helpful?
Yes
No
Tuesday, December 26th, 2017 AT 11:48 PM
Tiny
KEN
  • ADMIN
Yes we have the right car. You said that you don't have park but when you spray fluid the engine will run until the fluid runs out? This is telling me we have spark but not fuel. Can you try testing for power with the key on at the fuel pump relay?

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Wednesday, December 27th, 2017 AT 11:42 AM
Tiny
LYLE GIBSON
  • MEMBER
Yes the problem im having is when I turn the key on there is no sound from pump. As I have my wife crank it with a tester in the fuel pump connector its cranks over a few then tester lights up then nothing. She shuts the key off then trys cranking it the same thing happens. I put a spark tester with a light on it and when cranking it show spark then no spark. I checked the fuses and fuel pump relay seems to be getting power. Did notice that the fuse labeled ignition coil was doing the same thing no power with key on or cranking then shows power then nothing.
Was this
answer
helpful?
Yes
No
Thursday, December 28th, 2017 AT 3:49 AM
Tiny
LYLE GIBSON
  • MEMBER
In the photo I sent its the fuse below N1sticker bottom fuse labeled IGN COIL thats the one that has no power with key on or cranking
Was this
answer
helpful?
Yes
No
Thursday, December 28th, 2017 AT 3:52 AM
Tiny
LYLE GIBSON
  • MEMBER
Changed fuse nothing changes
Was this
answer
helpful?
Yes
No
Thursday, December 28th, 2017 AT 3:53 AM
Tiny
LYLE GIBSON
  • MEMBER
I really do appreciate you trying to help me with this problem cause im really stumped. Thank you so much!
Was this
answer
helpful?
Yes
No
Thursday, December 28th, 2017 AT 3:54 AM
Tiny
KEN
  • ADMIN
If the main relay is going out it will cause the problem have described. If that ends up being okay I would say it is the computer issue which will need to be programmed at a shop.

Here is the ECM location.

Check out the diagrams (Below)

Please let us know what you find. We are interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Thursday, December 28th, 2017 AT 1:08 PM

Please login or register to post a reply.

Recommended Guides