No power to EFI fuse

Tiny
COOKJ6927
  • MEMBER
  • 1993 TOYOTA 4RUNNER
  • 3.0L
  • V6
  • 4WD
  • AUTOMATIC
  • 190,000 MILES
Was driving up and it shut off. Cranks but no start. Fuse is good for EFI but no power to it.
Do you
have the same problem?
Yes
No
Monday, August 20th, 2018 AT 9:12 AM

5 Replies

Tiny
STEVE W.
  • EXPERT
If there is no power to either leg of the EFI fuse itself check the AM2 fusible link in the same box for power. It powers the EFI fuse and relay. If it has power and tests good then it could be a bad connection between the terminals of the fuses through the white/red stripe wire under the fuse box, or a bad connection terminal in the box itself. If you wanted to test that you could make a fused jumper wire using a 15 amp fuse and connect it between battery positive and the EFI fuse terminal. If it starts then the wiring is suspect.
Was this
answer
helpful?
Yes
No
+2
Monday, August 20th, 2018 AT 10:12 AM
Tiny
COOKJ6927
  • MEMBER
I jumped it with a fused jumper fired right up, ran maybe ten minutes then shut off again. I am tracing wires now thanks for the help.
Was this
answer
helpful?
Yes
No
Monday, August 20th, 2018 AT 1:18 PM
Tiny
STEVE W.
  • EXPERT
That sounds like there is another issue as well as the fuse box. Perhaps a short. Do you have a wiring diagram?
Was this
answer
helpful?
Yes
No
+1
Tuesday, August 21st, 2018 AT 2:34 PM
Tiny
COOKJ6927
  • MEMBER
No, I do not have the diagram. It is a 3vze motor.
Was this
answer
helpful?
Yes
No
Thursday, August 23rd, 2018 AT 7:39 AM
Tiny
KEN
  • ADMIN
Hello,

Here is the engine and EFI relay wiring diagrams which is powered by the IGN fuse 7.5 amp. Here is a guide to help you test the fuse and the location of the fuse as well:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Check out the diagrams (below). Please let us know what you find. We are interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Saturday, August 25th, 2018 AT 3:06 PM

Please login or register to post a reply.

Sponsored links