No power and red light on dash

Tiny
HEAVENLEE49
  • MEMBER
  • 2004 DODGE DURANGO
  • 5.7L
  • V8
  • 2WD
  • 240,000 MILES
I went to start my truck when I turned the key all the lights went black and the red security light came on. I checked the battery and it was good the key battery is fine and it is from what I understand programmed. I unhooked the battery for a bit and when I reconnected it there was a vibrating clicking noise coming from what I'm pretty sure was the fuse box under the hood, and the red light on my dash was flashing while it made the ticking noise. I put the key in clicked it on and off 4 or 5 times and it stopped but the light stayed on. Still didn't start. Please help!
Do you
have the same problem?
Yes
No
Tuesday, September 10th, 2019 AT 9:46 PM

1 Reply

Tiny
MASTERWRENCH
  • EXPERT
Welcome to 2CarPros!

From your initial description of the issue with the lights going black, it sounds like you have a poor battery cable connection somewhere. Since you disconnected and reconnected the battery, does everything still go black when you turn the key to Start? If so, I suggest following the link below to check all of the battery cable connections. Check the large eyelet/nut connection at the power distribution center (fuse box) under the hood. Verify both battery terminals are clean and tight. Follow the large negative battery cable to it's connection points. One should be located on the body to the rear of the battery and the other attached to the front right area of the engine block (see attached pictures).

https://www.2carpros.com/articles/everything-goes-dead-when-engine-is-cranked

Let me know what you find!
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2019 AT 4:49 AM

Please login or register to post a reply.

Recommended Guides