STEREO AND CLOCK NOT WORKING

1995 Nissan Maxima

Tiny

joziahbowen

April, 21, 2011 AT 8:37 PM

The fuse was burnt out but I changed it and still no sound from the speakers and the clock still is not working

Tiny

caradiodoc

April, 21, 2011 AT 8:47 PM

Did the new fuse blow? If all the fuses are good in the car and under the hood, pull the radio out and check for voltage on two pins in the connector. One should have 12 volts all the time and one should have 12 volts only when the ignition switch is turned on.

Tiny

joziahbowen

April, 21, 2011 AT 8:57 PM

Ok I just did thatand still no sound all you hear is the antennaa motor humming this problem is driving me crazy

Tiny

caradiodoc

April, 21, 2011 AT 9:08 PM

Then there's a problem in the radio.

Tiny

joziahbowen

April, 21, 2011 AT 9:09 PM

The new fuse didnot blow everything works except the radio and the clock the radio turns on but no sound and the antenna is broken of and the motor keeps humming but no sounds out of the speakers not even a muffled sound

Tiny

joziahbowen

April, 21, 2011 AT 9:31 PM

Ok thanks even if the antennas broken its still the radio

Tiny

caradiodoc

April, 21, 2011 AT 9:51 PM

Antenna doesn't affect the clock.

Tiny

joziahbowen

April, 21, 2011 AT 11:02 PM

I dont no then

Please login or register to post a reply.

Cabin Air Filter Replacement
Door Panel Removal & Speaker Replacement
Cabin Air Filter Replacement
Cabin Air Filter Replacement Chevrolet Tahoe
Replace Your Turn Signal Switch Like a Pro