Will not run after running hard and backfiring three or four times in a row

Tiny
GOOSE888
  • MEMBER
  • 2000 FORD F-150
  • 5.4L
  • V8
  • TURBO
  • 2WD
  • AUTOMATIC
  • 100,000 MILES
I was running it hard when all of a sudden it started backfiring, three or four times in a row. After that it would not run right so I put it in the shop and it had three broke plugs and a blown intake manifold gasket so I got them fixed. Now since I have them problems fixed all it wants to do when you get in the throttle hard is fluder early not pulling near like it should, while at the same time you can hear the supercharger winding but not pulling. The truck seems to run fine until you want to get in it hard but seriously I need help please! Thanks
Do you
have the same problem?
Yes
No
Wednesday, December 14th, 2016 AT 6:52 PM

3 Replies

Tiny
HMAC300
  • EXPERT
Scan for codes and check for vacuum leaks like a hose off, cracked broken etc.
Was this
answer
helpful?
Yes
No
-1
Thursday, December 15th, 2016 AT 6:24 AM
Tiny
GOOSE888
  • MEMBER
My mechanic scanned for codes and checked the hoses and found nothing. I am going to change the fuel filter and see if that helps.
Was this
answer
helpful?
Yes
No
Thursday, December 15th, 2016 AT 7:46 AM
Tiny
HMAC300
  • EXPERT
Before you check fuel filter check fuel pressure as well, see link. if this is a turbo make sure you have vacuum to your turbo valve.
https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator
Was this
answer
helpful?
Yes
No
Thursday, December 15th, 2016 AT 9:41 AM

Please login or register to post a reply.

Recommended Guides