Gurgling at start up

Tiny
LHARDEE1
  • MEMBER
  • MAZDA PROTEGE
2003 Mazda Protege ES, 63000 miles. Hi, I have had several problems. First, on a trip 350 miles from home, my fan belt broke. Was towed and had fan belt and timing belt replaced. Was released and towed again because the radiator was blown. Had the radiator and thermostat replaced the next day. All codes were fine. Got home. In city traffic, car was overheating, displaced by heater, got to a mechanic and was told that the mechanics probably didn't release the air in the line and was low on antifreeze and added 1/2 gallon of antifreeze. Few days later, engine light comes on. Spark in 3rd was arcing and may have gotten wet from fan backflow from radiator and needed new plugs and wires and maybe the coils. Fine. Plugs should have been replaced at 30k. Wires and plugs replaced, coils cleaned and ok. Before I took it in for the tune up, I noticed that on morning start up that there was a gurgling (stomache rumbling) sound under the dash. It runs fine and doesn't do it after running during the day. Also noticed water leakage/ dripping when parked that doesn't seem to contain coolant. Mechanic doesn't know what it is but after test driving thought he still smelled antifreeze and that I should watch it. It remains full and is not overheating. I have to do another 700m roundtrip this weekend with kids. Thoughts?
Do you
have the same problem?
Yes
No
Sunday, July 15th, 2007 AT 12:16 AM

1 Reply

Tiny
RASMATAZ
  • MEMBER
Get it recheck if you still smell anitfreeze could be the heater core leaking.
Was this
answer
helpful?
Yes
No
Sunday, July 15th, 2007 AT 12:28 AM

Please login or register to post a reply.

Recommended Guides