Check Engine Light?

Tiny
MHPAUTOS
  • EXPERT
Hi there,

That sounds way to much, I would be getting a second opinion on what is wrong, go to an independent and get a quote before you spend that sort of money.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
BETSY301
  • MEMBER
  • 2000 MAZDA PROTEGE
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 140,000 MILES
I got a transmissions flush done about 6 weeks ago now, since then the tranmission has been acting funny when I try to accelerate uphill it won't go into gear and until I take my foot off the gas and then replace it the car seems to fall into neutral. I took it back to the place I got the flush and they said it was overfilled by their tech so they drained 1 liter of fluid. The problem didn't get better so I took it back again, the place which I won't mention (Canada wide service center) told me to take it to a transmission specialist. I have a appt for next week but in the meantime the check engine light came on yesterday and the O/D light is blinking. Have any ideas on what the problem maybe? It seems to be intermittent to a constant thing.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Hi betsy301,

If the O/D is blinking, it means a system malfunction in the trans electrical or electronics had been detected.

Do you have any other things malfunctioning such as speedometer etc apart from the abnormal gear changes?

Get a scan done to find out what is the malfunction detected and you might solve the problem.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
BETSY301
  • MEMBER
Hi
to answer your question a scan was done and error code found in shifting between the 3rd and 4th gears. I guess they are going to remove the transmission to have a look?
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Hi betsy301,

Most probably not remove the whole trans, just the solenoids and valve body.

Wonder during transmission flush was the correct type and spec of fluid used?

Was the problem there before the flush?

Good luck.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
MONIKAMONIKA
  • MEMBER
  • 2000 MAZDA PROTEGE
2000 Mazda Protege Automatic 126556 miles

My check engine light came on. THey told me that it was running lean.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
2CARPRO JACK
  • EXPERT
Use carb spray and shoot it around the intake area to check for vacuum leaks, this will cause a lean condition. Also check/change the fuel filter. If both ok, fuel pressure test is next. Could even be the MAF (Mass Airflow Meter) out of range, try a special MAF cleaner to see if it remedies the problem
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
LPURPLE14
  • MEMBER
  • 2000 MAZDA PROTEGE
Engine Performance problem
2000 Mazda Protege 4 cyl Front Wheel Drive Manual

How complicated is replacing the ECG valve going to be? I want to know what I should prepare for as far as time and money. And does this valve have something to do with car performance going up hills specifically? My car seems to have trouble power wise when going up hills and the check engine light comes on when this occurs. Someone told me it is the ECG valve that is causing it to occur. Is this right?
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Hi lpurple14,

I believe you are referring to the EGR ( Exhaust Gas Recirculation ) valve.

When the CEL indicates, a trouble code would be stored in the engine computer.

Get a free scan done at Autozone and let me know the EXACT trouble code. The code would tell us what went wrong and how to go about rectifying the problem. Guessing is not going to work.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:30 PM (Merged)
Tiny
JORDOE28
  • MEMBER
  • 1999 MAZDA PROTEGE
Engine Mechanical problem
1999 Mazda Protege Front Wheel Drive Automatic 172119 miles

About 2 months ago I purchased a used Mazda Protege from a family friend. She had everything on it safetied and brought the car into Mazda for an engine test where they said everything was in really good condition. About a month after having it, the Check engine light came on while I was driving. Just to make sure, we unplugged the battery so it would reset, the light went away, but came on again in about 2 weeks. The car sounds great, starts great, all the fluids have been checked and double checked, the filters were just replaced before I bought it so is this just a sensor problem or should I be spending the money to take it in and get it checked?
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
BLACKOP555
  • EXPERT
Take it to autozone, have the code scanned and get back to me.

Autozone will scan for free!

Post the code, not what the code means.
Was this
answer
helpful?
Yes
No
+2
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
JORDOE28
  • MEMBER
I would but I live in Canada and we don't have an autozone here.

I will call around and see if I can find a place to scan for free and get back to you. Thanks
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
XOWEY
  • MEMBER
You can also start by performing a quick visual inspection, look to make sure that no connectors are disconnected under the hood, also make sure that the gas cap is tight and the sealing surface is clean. Let us know how it's going eh.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
JORDOE28
  • MEMBER
Well so far, since unplugging the battery and reseting everything, the engine light has not come back on. I started a Trip to record my mileage this time and so far I've driven 379 miles. However when it does come back on, like it did the previous times I resetted, I will take it in and get back to you guys. Thanks
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
WILSO379
  • MEMBER
  • 1999 MAZDA PROTEGE
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 114,500 MILES
I just bought this car off craigs list. I believe that was my first mistake because the engine light came on only 3 days after I had the car. I took it into the shop and they hooked it up and told me that the light was on because the last owner put bad gas in and a sensor in the cadilac converter went bad. About a week later I was sitting in my car with it running waiting for my sister to get off work and the o d off light came on. I cut my car off and back on and it went away. Do you think that this is a problem and do you know if it can be fixed or if my car will break down soon?
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
D5NUKE
  • MEMBER
This is also an issue on the ford explorers. There is a solenoid in the tranny that sticks. Causing this light to come on. When you shut down and restart it clears and seems fine. Not so in many cases have the tranny serviced and see if this clears the problem up New filter and fluid is always good on a used car. If the solenoid it bad have it replaced or you could cause more severe transmission issues.

Let me know how it goes and we can try to get it fixed for you.
PS: by the way I own ford explorer that had the exact same issue. Just needed tranny service
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
BLACKOP555
  • EXPERT
Doesnt sound too major in that case as it should be coming back on right away, when ever its your convinence I would take and have it looked at, just in case.
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
2CARPRO JACK
  • EXPERT
As far as the cat goes, those Mazdas went through them at about that mileage, nothing the previous owner did. You will notice it haveing driveability issues as the cat plugs itself up internally until it is replaced
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
JORDOE28
  • MEMBER
I am now at 600 miles and the Check Engine still has not come on after I reset it. Today I did however go to Mr. Lube to get an oil change. They also check everything and the only thing that they noticed was my PCV Emission valve was really plugged. So they replaced it for 12 dollars.

Could it of been the PCV valve being plugged causing the engine light to come on?
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)
Tiny
BLACKOP555
  • EXPERT
Yes that can cause the problem! It can cause the fuel mixture to show as lean or rich. And can also mess with the idle!
Was this
answer
helpful?
Yes
No
Friday, July 24th, 2020 AT 6:31 PM (Merged)

Please login or register to post a reply.

Sponsored links