Loss of power

Tiny
HOWARD DEMPSEY
  • MEMBER
  • 2008 CITROEN C4
  • 1.6L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 71,655 MILES
When I start car an rev it, it will only rev till 3500 rpm's. But if I give the accelerator a quick flick with my foot it goes back to normal. This is the same also when driving the car, very slow taking off until you flick the accelerator quickly. Also once the rpm drops below 1000 rpm's it goes back to not revving over 3500 rpm's.
Do you
have the same problem?
Yes
No
Tuesday, August 9th, 2016 AT 10:47 AM

3 Replies

Tiny
KEN
  • ADMIN
Hi there,

Is the check engine light on? if so you need to run the codes to see what they are and get back to us.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please let us know what you find so it will help others.

Best, Ken

Was this
answer
helpful?
Yes
No
Saturday, August 20th, 2016 AT 1:59 PM
Tiny
HOWARD DEMPSEY
  • MEMBER
Hi ken. I have no warning lights on. Left it 2b diagnosed and had a vacuum test done and everything appears to be normal, there looks like a new turbo had been replaced at one stage+ new egr valve. It is the egs gearbox car. Like I said b4 when stationary and started it will rev slowly but a couple of pumps of accelerator it restores power but if u let it drop below 1000rpm it will rev slowly again. Nobody seems to know what problem is, hope you can help.
Was this
answer
helpful?
Yes
No
Wednesday, August 24th, 2016 AT 8:55 AM
Tiny
RENEE
  • ADMIN
That does sounds weird, It might be a problem with a plugged exhaust system. Try disconnecting it it and retry the engine.
Was this
answer
helpful?
Yes
No
Monday, August 29th, 2016 AT 9:34 PM

Please login or register to post a reply.

Sponsored links