Car would lose power when I would come to a stop and sometimes stall?

Tiny
INKYJC513
  • MEMBER
  • 2003 CHEVROLET IMPALA
  • 3.4L
  • V6
  • 2WD
  • AUTOMATIC
  • 135,000 MILES
Then weeks later, it would struggle to accelerate over 15-20 MPH and it sounds and feels like it’s running rougher. Now when I start it, it shakes really rough and won’t stay running more than a few seconds.
Do you
have the same problem?
Yes
No
Tuesday, October 4th, 2022 AT 7:08 AM

1 Reply

Tiny
KEN L
  • ADMIN
It sounds like the engine is misfiring but if you can upload a short video of the engine running, (under the hood) it will help. We need to run the codes to see what comes up. Also, I would change out the spark plugs and service the throttle bore.

Here are guides to help and instructions in the images below to help you fix your car:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

and

https://www.2carpros.com/articles/how-to-tune-up-a-car-engine

Spark Plug Type .................... AC Delco 41-940

Tighten
- If installing the spark plugs to a new cylinder head tighten the plugs to 20 N.m (15 lb ft).
- If installing the spark plugs to an existing cylinder head tighten the plugs to 15 N.m (11 lb ft).

1. Install the spark plug wires to the spark plugs.
2. Release the J 41131 and return the engine to the original position.
3. Install the engine mount struts.

Check out the images (below). Let us know what happens and please upload pictures or videos of the problem.
Was this
answer
helpful?
Yes
No
Tuesday, October 4th, 2022 AT 10:49 AM

Please login or register to post a reply.

Sponsored links