“No Bus” message on dashboard

Tiny
SPRISELLA
  • MEMBER
  • 1999 DODGE RAM
  • 5.9L
  • 6 CYL
  • TURBO
  • 4WD
  • AUTOMATIC
  • 210 MILES
Hi, if someone could give me pointers that’d be great. So, I got the “No bus” message on my dash. Lost all gauges, engine light, fuel light, etc. Also, my truck was stuck in second gear. Looked up the codes (920, 921, 999) that was displaying all related to the computer, therefore. I replaced the computer last night thinking it was the issue and it was not I still have the same message and codes and no gauges. I’ve been doing a lot of research on this because I need my truck and I’ve checked all wiring. I watched a YouTube video last night where this guy had the same exact issue, and it was his governor transmission solenoid. Just curious if that could be my issue as well? At this point I’m willing to try anything. Keep in mind my truck still starts no issue. I’m no mechanic, please help.
Do you
have the same problem?
Yes
No
Sunday, November 21st, 2021 AT 3:56 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

The codes you have are all related to the instrument cluster/CAN

920 Cluster / no speed message from the PCM

921 Cluster / no distance signal from PCM

999 Indicated an error message is saved and to retrieve them via the cluster trip odometer reset button.

Have you checked to see if the same codes are stored?

___________________

As far as the issue, it sounds like there is a breakdown of communication via the CAN bus system or the cluster itself is bad. Is the vehicle running properly? Other than the issues with the cluster, is the transmission still causing issues? Is the vehicle drivable?

If you look below, I attached the diagnostics for the codes. Take a look through them and let me know if you are comfortable performing them. Also, let me know if you have other questions.

Take care,

Joe

See pics below.
Was this
answer
helpful?
Yes
No
Sunday, November 21st, 2021 AT 7:13 PM

Please login or register to post a reply.

Sponsored links