1995 Honda Civic car stalls

Tiny
ANDYBOY123
  • MEMBER
  • 1995 HONDA CIVIC
  • 4 CYL
  • FWD
  • MANUAL
  • 140,000 MILES
Hi I bought a 95 civic bought 4 months ago it has been driving fine until bout a week ago it has been acting up out of nowhere I was driving then all the sudden the check engine light came on then it went away then the car just died sometime its takes awhile to start back up any idea? I only changed so far the spark plugs and fuel filter
Do you
have the same problem?
Yes
No
Tuesday, December 8th, 2009 AT 6:44 PM

4 Replies

Tiny
KHLOW2008
  • EXPERT
Hi andyboy123,

Have you tried retrieving the troube code?

Bridge the SCS and turn ignition switch ON. Count the blinking of the CEL to get the code.


http://www.2carpros.com/forum/automotive_pictures/192750_SCS95Civic_1.jpg

Was this
answer
helpful?
Yes
No
Thursday, December 10th, 2009 AT 5:28 AM
Tiny
ANDYBOY123
  • MEMBER
Yes actually I did that yesterday the check engine light stayed on and the srs light was the one that kept blinking I left it for about 2 mins and and nothing happend check engine light just stayed on wasn't blinking at all
Was this
answer
helpful?
Yes
No
Thursday, December 10th, 2009 AT 7:14 PM
Tiny
ANDYBOY123
  • MEMBER
Actually my friend just told me today his honda was doing the same thing as mine and he said it was his alternator and actually I member water from the radiator came out and it got all over the engine I cleaned up most of it but I know right now the alternator is actually all white im assuming from the water of course you think it could be that because when the temp get to normal thats usally that's wen the check engine light comes on then goes away then engine will die
Was this
answer
helpful?
Yes
No
Thursday, December 10th, 2009 AT 7:20 PM
Tiny
KHLOW2008
  • EXPERT
I am having difficulty understanding your explanation.

When the alternator fails, the CEL would not be staying ON when ignition switch is turned ON. Only the charge indicator light would be staying ON.

When the CEL stays on, either the ECU is faulty or one of the sensors has been detected to be faulty or disconnected. When ignition switch is turned ON, the CEL would blip before staying ON.

Are you able to start the vehicle now?
Did you retrieve the trouble code?
Did the engine overheated when it stalled?
Was this
answer
helpful?
Yes
No
Friday, December 11th, 2009 AT 10:07 AM

Please login or register to post a reply.

Recommended Guides