Hard to start

Tiny
BRIAN DAWSON
  • MEMBER
  • 1996 GMC
  • 4.3L
  • 6 CYL
  • 112,227 MILES
1996 Jimmy 4.3 cpi. Hard to start when cold. Will start then shut off. Rapidly brake light and ABS light come on, vehicle stalls out. Runs fine after warned up, but still hard to start hot or cold.
Do you
have the same problem?
Yes
No
Tuesday, March 7th, 2017 AT 8:51 AM

9 Replies

Tiny
HMAC300
  • EXPERT
Check fuel pressure with a gauge auto parts rent it. should be 60-66 psi see our link.
https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator
Was this
answer
helpful?
Yes
No
Tuesday, March 7th, 2017 AT 9:24 AM
Tiny
BRIAN DAWSON
  • MEMBER
Checked pressure 62 psi bleed down when running to 58.
Was this
answer
helpful?
Yes
No
Tuesday, March 7th, 2017 AT 1:00 PM
Tiny
HMAC300
  • EXPERT
Should be 60 at least all the time when truck is shut off what is the reading after five minutes?
Was this
answer
helpful?
Yes
No
+1
Tuesday, March 7th, 2017 AT 1:10 PM
Tiny
BRIAN DAWSON
  • MEMBER
Drops to 40.
Was this
answer
helpful?
Yes
No
Tuesday, March 7th, 2017 AT 1:11 PM
Tiny
HMAC300
  • EXPERT
It should not drop that much only about 10 psi. Check the items in picture as it can be a regulator, pinched line, filter or injectors leaking.
Was this
answer
helpful?
Yes
No
Tuesday, March 7th, 2017 AT 1:25 PM
Tiny
STEVE W.
  • EXPERT
Do you mean you have to crank the engine a lot or that it starts then shuts off and you need to do that a few times until it runs good?

Do you hear the fuel pump trigger on for a couple seconds when you turn the key?
Check the fuel pressure and whether it holds the pressure when you turn off the key.
Has the gas mileage gotten worse?
If yes the CPI unit may have a bad regulator. The problem is that it is inside the intake manifold. The pressure check may reveal the problem.
Was this
answer
helpful?
Yes
No
Tuesday, March 7th, 2017 AT 5:40 PM (Merged)
Tiny
BRIAN DAWSON
  • MEMBER
Crank over a lot and will start then shut off multiple times to get it to run you must give it fuel until it warms up. Pressure check showed 62 psi at beginning when running bleed down to 58 with key off it will drop to between 40 and 45 after five to seven minutes. I do hear the pump running when I turn the key on.
Was this
answer
helpful?
Yes
No
Tuesday, March 7th, 2017 AT 5:40 PM (Merged)
Tiny
KEN
  • ADMIN
If I can step in here, please check the engine for vacuum leaks, here is a guide to help you.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

Also clean the IAC motor

https://www.2carpros.com/articles/throttle-actuator-service

Please let us know what happens.

Best, Ken
Was this
answer
helpful?
Yes
No
Friday, March 10th, 2017 AT 11:15 AM
Tiny
STEVE W.
  • EXPERT
OK you hear the pump run when you turn on the key. Try turning the key on/off a few times to trigger the pump and pressurize the system fully, then see if it starts and runs OK. If so check the oil pressure switch, it turns on to provide power to the pump after the ECM primes the system. BUT if yours is dropping pressure that prime may not be enough to build oil pressure to trigger the switch.
Was this
answer
helpful?
Yes
No
Friday, March 10th, 2017 AT 6:26 PM

Please login or register to post a reply.

Recommended Guides