Grinding noise when accelerated then car shut off

Tiny
KATIEISREBEL
  • MEMBER
  • 1999 FORD ESCORT
  • MANUAL
  • 209,263 MILES
I noticed my car was making a loud sort of grinding sound that would get louder when I pushed on the gas. Almost as soon as I noticed this he car started to lose speed even though I was pushing on the gas. Then about twenty seconds later it lost all power and I coasted off to the shoulder. That is when I noticed smoke coming from under the hood. If I try to start it now, it tries to turn over but starter wont engage and just grinds.
There is nothing obvious that has gone wrong or broken, it didn't overheat, it has plenty of oil and has plenty of water.
Any thoughts?
Do you
have the same problem?
Yes
No
Tuesday, June 11th, 2019 AT 7:34 PM

1 Reply

Tiny
SCWICKEDSTANG
  • EXPERT
Hello,

Unfortunately this sounds like your oil pump could have failed causing your engine to seize up. Your engine's bearings run on a thin layer of oil that lubricates all the moving parts. If the oil pumps goes out then the engine oil will not be pumped around the engine to lubricate it. I would suggest that you remove the valve cover and inspect the camshaft. This would be the first component to seize up and would show the most damage as it is the furthest from the oil pan and the oil pump. I have included a couple of links below for you to go to.

https://www.2carpros.com/articles/engine-noises
https://www.2carpros.com/articles/high-or-low-engine-oil-pressure

Please go through this guide and get back to us with what you find out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Tuesday, June 11th, 2019 AT 10:10 PM

Please login or register to post a reply.

Recommended Guides