Instrument Cluster

Tiny
UNC8116
  • MEMBER
  • 2002 FORD WINDSTAR
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 64,536 MILES
I have a 2002 ford windstar that has 64536 miles on it. About a week ago the speedometer stopped working, the overdrive light flashes, abs and brake lights are on and the a/c stopped working. The first thing I did was to check the fuse. I found it was blown I replaced it and a week later it blew again. I took it to ford and they said without looking at it thoroughly that the cluster was out and needs to be replaced at $1200. Is it possible that I could have a sensor out, I have checked the wires and cant find a short. Thanks
Do you
have the same problem?
Yes
No
Tuesday, June 2nd, 2009 AT 7:34 PM

3 Replies

Tiny
JIS001
  • EXPERT
You would need to find a wiring diagram to see what else is in that circuit with the speedometer. It would be better if you took it in to someone who specializes in electrical or pay for diagnosis at the dealer. What Ford gave you was just a guess and not a diagnosis?
Was this
answer
helpful?
Yes
No
Wednesday, June 3rd, 2009 AT 8:08 PM
Tiny
1RCASE1
  • MEMBER
I had the same problem and installed a used cluster it worked great got the unit for $150.00 from a salvage yard.
Was this
answer
helpful?
Yes
No
Thursday, June 4th, 2009 AT 7:27 AM
Tiny
JIS001
  • EXPERT
Good work on that. Please use 2Carpros anytime.
Was this
answer
helpful?
Yes
No
Thursday, June 4th, 2009 AT 10:33 AM

Please login or register to post a reply.

Recommended Guides