1993 Ford Tempo Engine Cooling problem

Tiny
TENNAYIA
  • MEMBER
  • 1993 FORD TEMPO
Engine Cooling problem
1993 Ford Tempo 4 cyl

My 93 Ford Tempo overheated so I had a friend look at it and replaced the heater hose. It still overheated so they said it was the head gasket. Which he then replaced also. The problem continued so I then replaced the anti-freeze, had the spark plugs and thermostat fixed, which solved the heater problem but the car is still running hot. I had a second opinion and they then said that some rings needed to be replaced in the engine because of the oil line now. Which the engine would have to be taken out and put on a machine and it would cost at least $800? Can you please assist me with this problem and are they correct?
Do you
have the same problem?
Yes
No
Wednesday, December 9th, 2009 AT 12:09 PM

4 Replies

Tiny
FIXITMR
  • MEMBER
The diagnosis sounds like BS to me? The only rings I can imagine are the piston rings? Why that has anything to do with overheat is beyond me! I think you need a more detailed explanation!
So you are saying that this problem happened suddenly after many miles of trouble free service from the car? Anybody check the waterpump and it's belt and idler pulley? Is the radiator fine? Maybe the head is cracked?
Was this
answer
helpful?
Yes
No
Thursday, December 10th, 2009 AT 12:42 AM
Tiny
TENNAYIA
  • MEMBER
Yes I have not had any problems until now. I HAD THE HEAD GASKET AND THERMOSTAT replaced. It still overheats. I think the radiator is fine. There are no leaks but I don't know if they checked the water pump. Please help!
Was this
answer
helpful?
Yes
No
Friday, December 11th, 2009 AT 6:20 PM
Tiny
DANNYR2009
  • MEMBER
I am no expert but heard that if you see white smoke, that mean the engine is burning antifreeze? If I wouldn't see any white smoke while the engine is running, I would make sure that the radiator is not blocked or some. Maybe check the radiator hose going out from the engine is hot, making sure the hot liquid is circulating?
Was this
answer
helpful?
Yes
No
Monday, December 14th, 2009 AT 4:24 PM
Tiny
FIXITMR
  • MEMBER
[quote="Tennayia"]yes I have not had any problems until now. I HAD THE HEAD GASKET AND THERMOSTAT replaced. It still overheats. I think the radiator is fine. There are no leaks but I don't know if they checked the water pump.[Quote]

you need someone else to check things out for you? This place is for advice, not actual 'help'. Rather than spend big money I would get another cheap car that runs good.
Was this
answer
helpful?
Yes
No
Monday, December 14th, 2009 AT 8:08 PM

Please login or register to post a reply.

Recommended Guides