1996 Ford Ranger Check engine light.

Tiny
TARHEEL9
  • MEMBER
  • 1996 FORD RANGER
  • 4 CYL
  • 2WD
  • MANUAL
  • 500,000 MILES
My check engine light stays on. I got the codes read and it said to change the oxygen sensors, so I did. Now it says to change the front oxygen sensor. I've had my computer reset several times and the light will stay off until I turn off and restart the vehicle. I even took the front sensor back and exchanged it for another one, because I thought the first sensor might be a bad one. I just had a tune up, and got a new exhaust system from front to back. Anyone have any suggestions?
Do you
have the same problem?
Yes
No
Tuesday, July 6th, 2010 AT 8:57 AM

4 Replies

Tiny
JIM SHIRRON
  • MEMBER
I've seen lots of oxygen sensors w/connection problems, I guess because they're so close to dirt & heat. With 1 sensor replaced twice & still same code, it just about has to be some kind of wiring problem. Let me know if you get it fixed, and what you did, I'd like to know.
Was this
answer
helpful?
Yes
No
Tuesday, July 6th, 2010 AT 9:33 AM
Tiny
SATURNTECH9
  • MEMBER
First of all thank you so much for your donation. Let's start with what code's did you have before you changed the sensor's and what did you change. Also what code's you have now?
Was this
answer
helpful?
Yes
No
Friday, July 9th, 2010 AT 1:05 PM
Tiny
TARHEEL9
  • MEMBER
Hey guys. Thanks so much for your input.I found a small crack at the connection to the ignition coil, and also a blown fuse under the hood that had something to do with the oxygn sensor. I changed these out and got it to pass inspection.
Was this
answer
helpful?
Yes
No
+2
Friday, July 9th, 2010 AT 5:11 PM
Tiny
SATURNTECH9
  • MEMBER
Glad to hear you got you car all figured out and passed inspection thank you for using 2carpros.
Was this
answer
helpful?
Yes
No
Friday, July 9th, 2010 AT 8:19 PM

Please login or register to post a reply.

Recommended Guides