Anti lock light on

Tiny
RANGERDANGER17
  • MEMBER
  • 1991 FORD RANGER
Brakes problem 4 cyl Two Wheel Drive Manual 289, 00 miles

my rear anti lock light comes on and stays on but my abs works. I have replaced the abs hydraulic unit abs wheel speed sensor in the rear end what else could it be bad sensor or what?
Do you
have the same problem?
Yes
No
Monday, December 29th, 2008 AT 5:07 PM

1 Reply

Tiny
KEN
  • ADMIN
If the ABS light is on the ABS system is not working. The light means it disabled. I would think it would be the rear sensor which is a common failure. Here is a guide and diagrams (below) on how to test and then replace the sensor.

https://www.2carpros.com/articles/abs-wheel-speed-sensor-test

REMOVAL
At the rear axle housing pull the wiring harness connector from the speed sensor.

Remove the speed sensor hold down bolt and remove the speed sensor from the rear axle housing.
INSTALLATION
Clean the rear axle housing mounting surface. Use care to prevent dirt from entering the rear axle housing.
Inspect and clean the magnetized sensor pole piece to make sure that it is free from loose metal particles which could cause erratic system operation. Inspect the speed sensor O-ring for damage and replace if necessary.

Lightly lubricate the speed sensor O-ring with motor oil, align the bolt hole, and install.
NOTE: Do not apply force to the plastic sensor connector. The sensor flange should slide to the mounting surface. This will make sure the air gap setting is between 0.127-1.143 mm (0.005-0.045 inches) .

Install the speed sensor hold-down bolt and tighten to 34-40 Nm (25-29 ft. lbs.) .
Push the connector on the speed sensor.

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+1
Saturday, September 9th, 2017 AT 7:09 PM

Please login or register to post a reply.

Recommended Guides