WITH NO IGNITION

1986 Ford Ranger

Tiny

Cubpilot2

December, 4, 2006 AT 3:06 AM

1986 Ford Ranger 140,000 2.9 V6 Truck was running ok when parked but when tried to start we found that we had no spark. Engine turns over fine. Replaced the ignition module and the coil but still nothing.
Looking for ideas. Thanks

6 Answers

Tiny

Bruce Hunt

December, 4, 2006 AT 7:22 AM

The coil feeds the distributor. Is there a good spark at the distributor?

Tiny

catch_15

December, 4, 2006 AT 10:54 AM

Try replacing the pick up coil.

Tiny

Cubpilot2

December, 9, 2006 AT 2:48 AM

I am not getting any spark from the coil except for a very weak yellow spark when using jumper cables at which time I also get a very weak spark from the plug wires. With only the battery cranking (new bat.) I get nothing.

Is the " pick up coil" the same as the " stator" on this unit?

Tiny

catch_15

December, 9, 2006 AT 10:20 AM

No, it's not the same as the starter. If you go to the auto parts store, they should know what you're talking about. I'm just assuming they will, because the stores around here hire a bunch of idiots.

Tiny

Cubpilot2

December, 9, 2006 AT 9:31 PM

Replaced the pick up coil today and everything is working fine now. It is the same as what the chilton manual refers to as the stator assy.
Thanks so much for the help

Tiny

catch_15

December, 9, 2006 AT 9:32 PM

Glad I could help.

Please login or register to post a reply.

Replace Ignition Control Module
 Step by Step video GMC Yukon XL 2000-2006
How to read codes Chevrolet Blazer
Code Read Retrieval/Clear - Dodge Stratus