Running smooth until fuel fill

Tiny
BAKER150
  • MEMBER
  • FORD F-150
Everything was fine until I filled up the tank. 3 miles later the sputtering began. It never stalled, but initially acted like it wanted to. After several bottles of heet and 3 tanks of 93 octane, still happening. I have a 2003 Ford F150 triton 4.6L v-8. 93,000 miles. 1st problem ive ever had. Money is tight so I'm looking for answers, any suggestions? I really appreciate the help.

Scott
Do you
have the same problem?
Yes
No
Thursday, September 27th, 2007 AT 6:34 PM

4 Replies

Tiny
BMRFIXIT
  • EXPERT
Hi Scott
do you have check engine light on or blinks when driving

you can have the fuel tested

plus your baby getting ready for a tune up
@ 93k miles

but codes will help

good luck
let me know
Was this
answer
helpful?
Yes
No
Thursday, September 27th, 2007 AT 9:06 PM
Tiny
BAKER150
  • MEMBER
Yes, the engine light is on, but goes off after a few days, and then comes back on again about the same amount of time. Possibly the plugs are fouled. Tune up is a definate must soon.
Was this
answer
helpful?
Yes
No
Thursday, September 27th, 2007 AT 11:23 PM
Tiny
BLACKOP555
  • EXPERT
Have u noticed the fuel pump humming loud lately or does it do it now? If so its time for a new fuel pump have it tested. U have 2 fuel tanks? If so try other tank any better?
Was this
answer
helpful?
Yes
No
Monday, October 1st, 2007 AT 9:04 PM
Tiny
BMRFIXIT
  • EXPERT
Good luck with that

but still if you can get the codes for check engine light that will help a lot

let me know
Was this
answer
helpful?
Yes
No
Tuesday, October 2nd, 2007 AT 6:16 PM

Please login or register to post a reply.

Recommended Guides