1999 Ford F-150 90,000 miles 5.4 Triton V8

Tiny
CHICKEN-FARMER
  • MEMBER
  • 1999 FORD F-150
My f-150 has been trouble free since I purchased it used 6 years ago. Recently the oil pressure gauge intermittently indicates 0 pressure for several minutes, then will return to normal. The oil/coolant light also is illuminated. I have checked both oil and coolant levels and they are within limits. I assume it is an oil pressure sensor or sending unit problem because of the above oil pressure gauge problem. My check engine soon light illuminated for several days, but has now gone away. I understand by searching on the internet that ford doesn't have a "key sequence" for checking general OBT codes like other manufactures have.
Do you
have the same problem?
Yes
No
Sunday, July 1st, 2007 AT 2:59 AM

3 Replies

Tiny
JWALTH02
  • MEMBER
Take it to your nearest autozone or checkers and have them pull up the code for free then let us know what it is and we'll go from there, good luck.
Was this
answer
helpful?
Yes
No
Sunday, July 1st, 2007 AT 3:46 AM
Tiny
CHICKEN-FARMER
  • MEMBER
I live on a small island in alaska and unfortunately I don't have a "local" auto zone to take my truck to. I'm not terribly concerned with it because I have checked the fluids and know that they are within limits.

Thanks for the reply
Was this
answer
helpful?
Yes
No
Sunday, July 1st, 2007 AT 7:36 PM
Tiny
CHICKEN-FARMER
  • MEMBER
N/T
Was this
answer
helpful?
Yes
No
Monday, July 2nd, 2007 AT 8:53 PM

Please login or register to post a reply.

Recommended Guides