Instrument panel

Tiny
TUGGIS
  • 1995 FORD EXPLORER

I have a ford explorer and the instrument panel stopped working. No Tach, speedo, fuel, temp or volt meter. Is there a specific fuse for it or any suggestions? Thanks

Do you
have the same problem?
Yes
No
Saturday, June 17th, 2006 AT 9:51 PM

19 Replies

Tiny
TAURUSWHEEL
  • MEMBER

Do you have electronic dash? Check the ribbon connector, and or, any others, behind the dash, might be some work to get to it, I have heard of issues with it on other vehicles.

Was this
answer
helpful?
Yes
No
Sunday, June 18th, 2006 AT 9:51 PM
Tiny
WILLIAMLCOCHRAN2
  • 2002 FORD EXPLORER

Electrical problem
2002 Ford Explorer 6 cyl Two Wheel Drive Automatic

Hello everyone,

I have a problem with my 2002 Ford Explorer Sport Trac, my instrument cluster backlights do not luminate when I turn on my headlights. I checked the fuse that is supposed to correspond with the circuit and it appears to be fine. Can anyone tell me what the problem could posssibly be.

Thank you

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,244 POSTS

Check behind the dash to make sure none of the wiring harnesses are loose or damaged. Also, the power for the dash lights comes from the headlight switch. You may want to have that checked.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
BRATIE1
  • 2002 FORD EXPLORERFORD EXPLORER

I took my 2003 ford explorer the ford dealer to have the oil changed and when I picked it up it was fine. However, that same day when I turned the car off and then turned it back on for later use none of the instrument gauges worked. Windows would not roll down, the 4x4 would not work, the paddle lights would not work, etc. I took it back to the dealer the next day and they said it wasn't anything they did b/c they only changed the oil. They connected my car up to the computer for diagnosis, then checked and replaced fuses trying to assess the problem. Two hours later they said they believed the problem to be the instrument cluster. Okay I have them order the part and replace it as according to them the instrument clusters just go.

I pick up my car after they have had it for over a week and I am told that I need to bring in the keys for reprograming of the car. I take the keys in and wait for the reprograming. Once they say its done I go and get into the car and notice that the paddle lights on the vehicle still don't work and the interior lights are not working either. I go back in and tell the serviceman what is going on and he tells me that that part may have missed reprogramming and that I need to bring it back in tomorrow for that.

I do so and when I call to get my car I am told that they could not fix the problem b/c there is another problem, their diagnosis found that the central junctin box has an internal short and needs replacing, the cluster cost me over $300 dollars and now they say that this part is going to cost me $280 dollars. Do these parts just go out? Do they go out in conjuction with the other as they have stated? Should the computer diagn. The first time have been able to determine that both parts needed to be replaced the first time?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
2CARPROS KEN
  • ADMIN
  • 10,306 POSTS

Do all these problems happen at once. If so I would suspect a main fuse or a relay problem, if ok, the G.E.M. Which controls the fuctions metioned, could be bad. When you got it back did the gauges work?

Was this
answer
helpful?
Yes
No
-1
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
BRATIE1
  • MEMBER

All of these problems happened after I picked up my car from having the oil changed. When I got the car back from having the instrument cluster changed it was then they told me that the junction box needed to be changed since the paddle lights on the car would not work or the internal lighting when you open the doors.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
2CARPROS KEN
  • ADMIN
  • 10,306 POSTS

That doesn't look good. I would take it to a different dealer for a second opinion.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
PAULSALAS
  • 2002 FORD EXPLORER
  • 150,000 MILES

Gave another car a boost and now my gauges don't work and my vehicle dousn't start.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
KOKO.121
  • MEMBER

Did anybody check it by a scaning tool? If yes any trouble codes?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
WAYNEROBERT1978
  • 2003 FORD EXPLORER

2003 Ford Explorer

The instrument panel, radio, interior lights and power windows all stopped working at the same time. The A/C, wipers, and horn continue to work. What happened?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,244 POSTS

Have you checked the fuses both in the vehicle and under the hood?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
WAYNEROBERT1978
  • MEMBER

Every one of them. None are blown.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,244 POSTS

Fuses may look good but could be bad. Did you check them for continunity?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
WAYNEROBERT1978
  • MEMBER

I took each one out of an area that was not working. And put that fuse into a slot of an idea that was working and they continued to work. Telling me the fuses was not bad. I did that with each one.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
RENOB1954
  • 1997 FORD EXPLORER

Electrical problem
1997 Ford Explorer 6 cyl Four Wheel Drive Automatic

I have a light on, and it reads (CHECK GUAGES)
and some of my guages don't work.
Whats the problem here? Can you help please?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,244 POSTS

The light is on because one of the gauges are low or not working. Which gauges are not working?

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
RENOB1954
  • MEMBER

The gas guage, temp guage, oil guage, and batt guage
is not working. But the speedometer and tach is

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,244 POSTS

If the wiring is good going to the cluster, tight, and not damaged, first make sure there is power going to the plug in. If there is, the cluster itself is most likely bad.

Let me know what you find.
Joe

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)
Tiny
SAM JOHNSON
  • 2005 FORD EXPLORER
  • 4.0L
  • V6
  • 4WD
  • AUTOMATIC
  • 100,000 MILES

My SUV had a body lift and a new bumper installed. Now the tachometer, speedometer and the temperature gauges fail to work. Additionally the check gauge, check brakes and the battery icon are all lit up. And the digital read out is not functioning properly.

The car starts and the MAF is still working.

The car has been in three shops and it is driving me crazy.

I look forward to your help.

Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 2:18 PM (Merged)

Please login or register to post a reply.

Recommended Guides