2003 Ford Escort Fuel delivery

Tiny
BURNELLKENNETH
  • MEMBER
  • 2003 FORD ESCORT
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 81,000 MILES
My car died on me while driving last week. It acted as if it were running out of gas, so I got gas and it still wouldnt start. So, then I checked the fuel pump fuse(20-amp)under the hood and it was blown, so I replaced it with a 30-amp because that was all I had and it started.I then drove 15-miles and it started to cut-out again and blew that fuse too. We replaced the fuse and it woulnt start again. We pulled out the back seat and noticed the wiring clip to the fuel pump was burnt.I tested the fuel relay and fuel pump and are both good. Its just not getting power to the fuel pump when I turn on the key. The shutoff switch is also been reset and still doesnt start.
Do you
have the same problem?
Yes
No
Sunday, November 9th, 2008 AT 3:20 AM

2 Replies

Tiny
BMRFIXIT
  • EXPERT
Recheck the wiring
check for power at the pump and also check for a good ground
Was this
answer
helpful?
Yes
No
Sunday, November 9th, 2008 AT 6:10 AM
Tiny
DAVE H
  • EXPERT
As BMRFIXIT has said this seems like a wiring fault. Use a multimter to test you are getting power to the plug. If you are, then the plug is probably not connecting correctly because it is burnt. Replace the plug with new. If you are not getting power then you will have to trace the wire back for a breakage?
Was this
answer
helpful?
Yes
No
Sunday, November 9th, 2008 AT 6:26 AM

Please login or register to post a reply.

Recommended Guides