Engine quit running and will not start

Tiny
MATTL
  • MEMBER
  • 1999 FORD ESCORT
Four cylinder front wheel drive automatic 140,000 miles

Engine stopped running. Engine cranks but will not start. There was a slight burning plastic smell before the engine quit running. Engine is getting fuel, spark and compression.

What should I look for next?
Do you
have the same problem?
Yes
No
Thursday, October 8th, 2009 AT 2:38 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
If you are getting spark and fuel and have good compression, it should run unless it is out of time. Have you checked the timing belt? Also, is the spark you are getting a good hot blue snapping spark? Have you checked fuel pump pressure?
Was this
answer
helpful?
Yes
No
Monday, October 19th, 2009 AT 9:54 PM
Tiny
MATTL
  • MEMBER
Thank you for your response. The problem has been fixed.

I took my vehicle to a different shop (two weeks at the same shop without them finding the issue) and they called me back the next day. The timing belt and tension-er was bad. They checked the compression in all the cylinders and it was not right.
They pulled the timing belt cover and voila stripped belt.

I did mention about the timing belt to the previous shop after reading all the comments. It seems to be a common occurrence for the Escort.
Was this
answer
helpful?
Yes
No
Tuesday, October 20th, 2009 AT 1:46 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Glad you got it fixed. I had a feeling, based on what you said, it was timing related.

Let us know if you have questions in the future.
Was this
answer
helpful?
Yes
No
Tuesday, October 20th, 2009 AT 1:52 PM

Please login or register to post a reply.

Sponsored links