1998 Ford Escort No spark, now a buzzing noise out of compo

Tiny
WALTHAM41
  • MEMBER
  • 1998 FORD ESCORT
Electrical problem
1998 Ford Escort 4 cyl Front Wheel Drive Automatic

98 Escort ZX2 sport

The car ran, was parked for 3 days, then cranked over fine but would not start. Put small amount of fuel in throttle body, no start, Diagnosed no spark to spark plugs. Replaced crankshaft sensor, still no spark and now upon reassembly from installing crankshaft sensor, a box under air filter housing with large wiring harness makes a squealing/buzzing noise when battery connected and key turned on. Pulling the 30A fuel inj fuse stops buzzing.

Car still cranks over fine but will not start and now have the buzzing from box under the round air filter housing.

engine is a 2.0L ZeTech

not sure what the box is, haynes manual does not show it. Suspect it is a control module of some sort.
Do you
have the same problem?
Yes
No
Saturday, May 16th, 2009 AT 11:15 PM

2 Replies

Tiny
KEN
  • ADMIN
Hi, it sound like a control relay has gone bad inside for the control module; do you have five volts to the any of the sensors? Like TPS? Also check the injector ohms reading to make sure none are shorted. If not you may have to replace the main control module under the air filter. and recheck all fuses. Please use this page for further reference.

http://www.2carpros.com/how_to/how_to_test_an_ignition_system.htm

please let me know how it goes,
Was this
answer
helpful?
Yes
No
Tuesday, May 19th, 2009 AT 12:36 PM
Tiny
WALTHAM41
  • MEMBER
I changed out the main control module and the car is now running. Thank you for you help.
Was this
answer
helpful?
Yes
No
Friday, June 19th, 2009 AT 1:28 AM

Please login or register to post a reply.

Recommended Guides