2005 Ford Escape Ford Escape just died

Tiny
FSCOTT305
  • MEMBER
  • 2005 FORD ESCAPE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 67,000 MILES
My 2005 Escape has ran great. Regular maintenance and easy driving conditions. Parked it at a store. Came out and started it. It ran rough for a second then died. Started it back up and the engine was running extremely rough. Drove it two miles to my house and parked it. Now when I start it, it will run really rough for a few seconds then die. I changed the fuel and air filters on it, but no luck. The check engine light will come on sometimes and other times it does not. Also, light black smoke that turns blue comes out the tailpipe in the few seconds that it is running. Oil was changed about 1000 miles ago. Any suggestions?
Do you
have the same problem?
Yes
No
Monday, December 29th, 2008 AT 12:51 PM

2 Replies

Tiny
DAVE H
  • EXPERT
Do you have acccess to a code scanner? Even though the MIL is not staying lit. It will have codes stored. We really need the codes to pinpoint where the fault lies?
Was this
answer
helpful?
Yes
No
Monday, December 29th, 2008 AT 1:20 PM
Tiny
FSCOTT305
  • MEMBER
I do not have access to a code scanner. I called all of my local parts houses to see if they could rent me one to check my engine. They all told me no, that I need to bring the vehicle to them. Well, I can't do that, its not running. Just running through things in my head I pulled the IAC and started the Escape. It ran, but would occasionally backfire through the open port. Under normal circumstances I would just put the vehicle in the shop, but my budget is ectremely limited right now.
Was this
answer
helpful?
Yes
No
-1
Monday, December 29th, 2008 AT 3:33 PM

Please login or register to post a reply.

Sponsored links