Engine will not start or crank

Tiny
COUNTRYBOY69690
  • MEMBER
  • 2004 OLDSMOBILE ALERO
  • 3.4L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 126,000 MILES
Was driving it did good stoped some it started every time came home. Went out the next morning would not start. Turn the key on acted like it had drained battery. Checked it battery is good. All the lights work and wipers and fuel pump are all working normal. No security light on. Fuses are good, starter relay is good. Any help or advice is much needed as I need it running as soon as I can.
Do you
have the same problem?
Yes
No
Friday, March 2nd, 2018 AT 6:27 AM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good evening.

Did you check the battery with a voltmeter?
Also, do you have any way to check for fuel pressure and spark?

Roy
Was this
answer
helpful?
Yes
No
Friday, March 2nd, 2018 AT 5:05 PM
Tiny
COUNTRYBOY69690
  • MEMBER
After it sat there for three days I walked out got in it turned the key and it started right up. I tried it several times after that and it started every time. I do not know what was wrong, but to me it sounds like the ignition switch is going out on it. It had power every where but the starter and ignition switch where the wire going to the starter comes out may be wrong, but after three days of reading everything I could find on the internet that is the only thing I can think of it being. They cut way too many corners making that car just trying to get more money in their pockets.
Was this
answer
helpful?
Yes
No
Friday, March 2nd, 2018 AT 5:27 PM
Tiny
ASEMASTER6371
  • EXPERT
GM had their fair share of issue with the ignition switches.

I attached a wire diagram for you to view. Check the relay control side and load side.

Roy
Was this
answer
helpful?
Yes
No
Friday, March 2nd, 2018 AT 5:35 PM

Please login or register to post a reply.

Sponsored links