Engine cutting off, car wont start

Tiny
KEVROBBY
  • MEMBER
  • 2004 CITROEN C2
  • 1.6L
  • MANUAL
  • 56,000 MILES
Engine sometimes cuts off when approaching junction whilst I have my heaters, lights and windscreen wipers on, usually early in a morning (5.45ish) when its cold and sometimes raining. Had tests carried out on the car, they reported that the battery was good just needed a good re-charge, had a starter test that found cranking was normal and also underwent a charging test which found no problems. Sometimes car cranks over but doesn't start, so I re-charge the battery then it starts. Also sometimes, after re-charging the battery, it wont start and just makes a clicking noise, checked the spark plugs they are all fine and working! HELP PLEASE
Do you
have the same problem?
Yes
No
Sunday, November 24th, 2013 AT 7:57 AM

9 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
When it doesn't start, does the starter crank the engine, trying to start it, or is the only thing you hear is a clicking?
Was this
answer
helpful?
Yes
No
+1
Tuesday, November 26th, 2013 AT 10:55 AM
Tiny
KEVROBBY
  • MEMBER
Thanks for the response! Sometimes the starter cranks the engine but theres no life, so I recharged the battery then it starts. A few weeks down the line it doesnt start again and doesnt even crank over it just makes the clicking noise! Checked the spark plugs they look fine and are less than two years old and ignition coil less than 4 years old.
Was this
answer
helpful?
Yes
No
Tuesday, November 26th, 2013 AT 11:02 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If you are only getting a clicking sound, that tells me the battery is weak. When this happens, can you jump start the vehicle?
Was this
answer
helpful?
Yes
No
Tuesday, November 26th, 2013 AT 5:09 PM
Tiny
KEVROBBY
  • MEMBER
When the problem first started and it cranked over but didn't start, we tried jump starting it and nothing happened. When the clicking noise was happening we never tried jump starting it.
Was this
answer
helpful?
Yes
No
Tuesday, November 26th, 2013 AT 9:52 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Since this happens over a period of time (weeks), I feel either the battery needs replaced, the alternator may not be recharging the battery or there is an electrical draw on the battery that is causing it to get weak.
Was this
answer
helpful?
Yes
No
Wednesday, November 27th, 2013 AT 6:22 AM
Tiny
KEVROBBY
  • MEMBER
Thanks for your advice! At the garage today will let you know what they say
Was this
answer
helpful?
Yes
No
Wednesday, November 27th, 2013 AT 6:34 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I'll look for your reply.
Was this
answer
helpful?
Yes
No
Wednesday, November 27th, 2013 AT 6:37 AM
Tiny
KEVROBBY
  • MEMBER
Just got the car back now, they said the throttle body was removed and found an excessive build up of oil/carbon around the throttle butterfly so cleaned that thoroughly and reset the throttle adaptations.
Was this
answer
helpful?
Yes
No
Wednesday, November 27th, 2013 AT 8:40 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I have to be honest, I'm not sure how that is related to the no crank issues you had. Regardless, let me know if it is running good for you or if you have other questions.
Was this
answer
helpful?
Yes
No
Wednesday, November 27th, 2013 AT 9:24 AM

Please login or register to post a reply.

Recommended Guides