2007 Citroen C2 Starting problems

Tiny
NETHYSTEVO
  • MEMBER
  • 2007 CITROEN C2
  • 1.6L
  • 4 CYL
  • FWD
  • MANUAL
  • 60,000 MILES
Hello,
My citroen c2 just cut out on me last night after pulling off at a junction, I got about 20 yards and the engine just died, all of my electrics were working fine when this happened, I pulled over thinking I had just stalled and tryed to turn the car on and just got a "cranking noise". This is all that happened, I kept trying it and the same continious noise kept happening, luckly I managed to get a toe to my house. I then tryed it again and it started first time (making me look like a fool). Thinking it was alright and just a small glitch I then stupidly went back out in the car. Later that night it happened again and the exact same thing happened. The same cranking noise happened. It has never done this before and hope that it is nothing serious?
Cheers.
Steven.
Do you
have the same problem?
Yes
No
Sunday, January 26th, 2014 AT 2:53 AM

5 Replies

Tiny
MHPAUTOS
  • EXPERT
These problems can be very annoying. I would first get a scan done to see if there are any set fault code, not all codes will set a check light. Also when it will not start you will have to check for fuel pressure, spark and injection pulse, we need this info to get to the bottom of your problem.
Was this
answer
helpful?
Yes
No
Sunday, January 26th, 2014 AT 5:28 PM
Tiny
NETHYSTEVO
  • MEMBER
Sorry for late reply I have been pulling my hair out about this car, it has been at the garage since Wednesday morning and has had a map sensor replaced, after replacing this the boys at the garage said that the car was starting no bother but all of a sudden it's Idling at 3500rpm? This is just what I have been told from the mechanics, I had put a cda filter to the car and they are blaming it so are going to try the standard one back in, I can't see how an airfilter would make this much difference?
Cheers.
Was this
answer
helpful?
Yes
No
Thursday, January 30th, 2014 AT 3:26 PM
Tiny
MHPAUTOS
  • EXPERT
Problem is I have no detailed technical data on this car, I would be looking at the EGR system and also idle control stepper motor, the jump up in RPM would only be through a vacuum leak that is not constant, if it was constant it would idle all the time and the air filter will not cause this problem.
Was this
answer
helpful?
Yes
No
Friday, January 31st, 2014 AT 12:20 PM
Tiny
NETHYSTEVO
  • MEMBER
Ok, I got the car back today and it seemed back to normal, the standard airfilter was fitted and that new map sensor, but about 12 miles later I stopped at a junction and when I set off changing from 2nd to 3rd my car nearly died and put it's engine break on, it was only for 2 seconds and then back to normal, very strange considering I just got it back from the garage, so I made it home and went out in the car again this time the engine light is back on with the display reading "antipolution faulty"
Maybe the reason for the idling is due to the fact that I fitted the airfilter and maybe it wasn't connected properly for some unknown reason. But the car will be going back to the garage and if it isn't sorted then I'm giving up and buying a 100 corsa or something along those lines (will probably last longer at this rate!)
Cheers
Was this
answer
helpful?
Yes
No
-1
Friday, January 31st, 2014 AT 1:02 PM
Tiny
MHPAUTOS
  • EXPERT
Let me know what they find.
Was this
answer
helpful?
Yes
No
-1
Friday, January 31st, 2014 AT 2:32 PM

Please login or register to post a reply.

Recommended Guides