Reinstalled instrument cluster now sunroof, windows and radio do not work

Tiny
FRANCISCO LIMON
  • MEMBER
  • 2004 LINCOLN AVIATOR
  • 149,000 MILES
The sunroof, windows and radio are not working after I removed and reinstalled the instrument cluster. What did I do wrong and how can I fix it?
Do you
have the same problem?
Yes
No
Sunday, August 5th, 2018 AT 4:58 AM

3 Replies

Tiny
KEN L
  • ADMIN
Can I ask if the instrument cluster was used or the same one? If used you will need to have it initialized (programmed) to work with the car. Can you see if you have power at fuse #f1.31 please? Here is a guide and the fuse location:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Check out the diagrams (below). Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2018 AT 10:53 AM
Tiny
FRANCISCO LIMON
  • MEMBER
Thanks for replying Ken! The instrument cluster is the same one. I forgot to mention that ever since I did that the battery is also draining. The car will start when I charge the battery but not the next day. I will check the fuses and let you know.
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2018 AT 2:33 PM
Tiny
KEN L
  • ADMIN
It could be a coincidence the battery went bad. I would do this test to see if the battery passes.

https://www.2carpros.com/articles/car-battery-load-test

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2018 AT 9:53 AM

Please login or register to post a reply.

Related Instrument Cluster Replace/Remove Content

Instrument Cluster Replacement
VIDEO

Sponsored links