HELP>>>>

Tiny
PATSA12
  • MEMBER
  • DODGE NEON
I have a 05 Dodge 2.0 sx sport. It was having trouble starting for a couple weeks. Then few days ago it wouldnt go at all. Later that day it went but was tick tick tick while trying to start. We replaced spark plugs and starter. STILL tick tick tick while starting, sometimes would go sometimes not. We tryed boosting it yesterday and it went perfect. So out we go and get a new battery. STILL DOING IT>>> wont go without a boost at all now. Weve checked the alternator and the starter relay.
ANY ADVICE on what to check out next?
BTW>>> theres a wire that is attached to our fender in our car on the driver side. That wire was broken so we used connector and fixed it. Whats that wire for? Milage is 104k. Engine size is 4cylinder.
Do you
have the same problem?
Yes
No
Friday, September 14th, 2007 AT 11:47 AM

2 Replies

Tiny
RASMATAZ
  • MEMBER
Try checking the ignition switch and neutral safety switch
Was this
answer
helpful?
Yes
No
Sunday, September 16th, 2007 AT 4:54 AM
Tiny
PATSA12
  • MEMBER
Well. Since my last post. I called the dealership and they said it was probably my body control computer and that I can keep boosting it for now if I dont have the money to fix it. So we boost it. Drive about an hour out of town and all of a sudden the gauges start going nuts adn the car is turning itself on and off. Now it wont go AT ALL>> I got it towed back to town and took it in. The worked on it for 15 hours at Canadian tire and dont know They replaced the wires from the battery to the power distribution box and checked EVERYTHING>>> NO codes are coming up and they just phoned me and said they dont know. AHHHHHHHH Right now I hate my car. Im going to take it into the dealership tomorrow though. Can tire thinks its something to do with the power distributiion box. But wouldnt a code show up for that?
Was this
answer
helpful?
Yes
No
Sunday, September 16th, 2007 AT 1:01 PM

Please login or register to post a reply.

Recommended Guides