Cooling fans running all the time

Tiny
MKFARREN
  • MEMBER
I have not gotten to work much on this one, it is driveable so I have worked on other things, but today I put a code reader on it and I can post some running data if that will help. It is showing open circuit on fan, even though it is running. My assumption is the open circuit is one of the sensors that should be closed and the open circuit is telling the computer the fans should be on. Next step I believe would be checking any circuit that commands the fan on being open?
Was this
answer
helpful?
Yes
No
Sunday, May 20th, 2018 AT 7:31 PM
Tiny
KEN
  • ADMIN
The computer runs the fans, it sounds like its having a problem with the coolant fan control driver inside the PCM. If you checked the wiring I would try swapping the PCM out with a used one to see what happens. Here is the location.

Check out the diagrams (below). Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, May 21st, 2018 AT 9:54 AM
Tiny
MKFARREN
  • MEMBER
I tried one I had bought from eBay back when he got the car thinking the PCM was the issue. It showed the same error, although I could only run it a few seconds before it shut the engine down. It has the security key.
Was this
answer
helpful?
Yes
No
Monday, May 21st, 2018 AT 3:43 PM
Tiny
MKFARREN
  • MEMBER
Should I try a different one? I was able to return that one.
Was this
answer
helpful?
Yes
No
Monday, May 21st, 2018 AT 3:53 PM
Tiny
KEN
  • ADMIN
If you have replaced the sensor and checked the wiring it only leaves the PCM.
Was this
answer
helpful?
Yes
No
Tuesday, May 22nd, 2018 AT 10:10 AM
Tiny
MKFARREN
  • MEMBER
Great, I have a programmed one on the way, I will let you know what I find.
Was this
answer
helpful?
Yes
No
Tuesday, May 22nd, 2018 AT 2:59 PM
Tiny
KEN
  • ADMIN
Sounds good.
Was this
answer
helpful?
Yes
No
Wednesday, May 23rd, 2018 AT 10:31 AM
Tiny
MKFARREN
  • MEMBER
Installed the new computer and same p0481. I can post some live data from the reader tomorrow if that will help. I cannot find anything out of the ordinary yet. I have put the original computer back since it checks out because the new computer throws a p0513 for invalid SKIM key.
Was this
answer
helpful?
Yes
No
Saturday, May 26th, 2018 AT 5:33 PM
Tiny
KEN
  • ADMIN
That code is cooling fan circuit failure we must be missing something int he wiring or the relay or fan motor is bad.

This guide will help you test the relay:

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2018 AT 11:50 AM
Tiny
MKFARREN
  • MEMBER
Since both cooling fans are running nonstop, would that rule out bad fan motors?
Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2018 AT 4:52 PM
Tiny
KEN
  • ADMIN
Yes, I do not think that will create the problem the system monitors the trigger side of the relays.
Was this
answer
helpful?
Yes
No
Monday, May 28th, 2018 AT 9:41 AM
Tiny
MKFARREN
  • MEMBER
Thanks, as soon as the rains pass through I will get back at it, probably Friday evening. I will keep you posted.
Was this
answer
helpful?
Yes
No
Tuesday, May 29th, 2018 AT 6:56 PM
Tiny
KEN
  • ADMIN
Please do.
Was this
answer
helpful?
Yes
No
Wednesday, May 30th, 2018 AT 10:37 AM
Tiny
MKFARREN
  • MEMBER
Sorry for the delay, life happened around here the last couple of months, my Grandmother got sick and passed at 93 years old. The car is still doing the same. Son's driving it because it is not causing an issue other than bugging me, lol. I plan to get back to running through the relay tests hopefully tomorrow night.
Was this
answer
helpful?
Yes
No
Sunday, July 22nd, 2018 AT 8:23 PM
Tiny
KEN
  • ADMIN
I am sorry to hear about your grandmother, my condolences. Please let us know if you need help with anything and keep me informed about the relay test.
Was this
answer
helpful?
Yes
No
Monday, July 23rd, 2018 AT 10:27 AM
Tiny
MKFARREN
  • MEMBER
So far I still have not turned up anything. I got to work on it the last couple of days and I have not turned up a short or break in the wiring. One thought I had was overcharged AC system. That does not seem to be the case either. According to my gauge, it was overcharged but after evacuating out enough to bring the low side down into the 30's, I do not have cold air, so I am thinking my gauge is bad. I am going to use dad's to refill today. Considering a radiator mount temperature sensor/relay and letting the car win, lol. Unsure about that though because it will not spin the fans when the AC is turned on.
Was this
answer
helpful?
Yes
No
Sunday, August 5th, 2018 AT 9:41 AM
Tiny
KEN
  • ADMIN
To make sure it not a Freon issue I would get set of gauges you can find on Amazon for about $40.00 and follow this guide.

https://www.2carpros.com/articles/re-charge-an-air-conditioner-system

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Sunday, August 5th, 2018 AT 4:08 PM
Tiny
MKFARREN
  • MEMBER
AC is back to normal and cooling. Replaced the high pressure AC switch too while I had it evacuated. The snap has been broken since we got it and it bugged me. I did get a new code today and I think it is what I was suspecting. Today's code additionally is P0645 A/C Clutch Control Circuit Open. I am betting that is the issue and it has gone to a fail safe thinking the AC is always on. I will trace that down hopefully this week and report back.
Was this
answer
helpful?
Yes
No
Sunday, August 5th, 2018 AT 7:28 PM
Tiny
KEN
  • ADMIN
Okay, it sounds like we are getting closer.
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2018 AT 9:34 AM
Tiny
MKFARREN
  • MEMBER
Back on this one at last, so far I have gone back and traced the cooling fan circuits from the fans through the harnesses through the fuses and relays and everything shows continuity where it should. The open circuit on the AC clutch has disappeared as fast as it came and never reappeared. I am still getting open circuit on fan 2. Just when I thought I was getting somewhere, lol. I am at a loss.
Was this
answer
helpful?
Yes
No
Wednesday, August 15th, 2018 AT 6:35 PM

Please login or register to post a reply.

Sponsored links