Climate control not working properly

Tiny
AUSTIN REED
  • MEMBER
  • 2013 CHEVROLET MALIBU
  • 2.0L
  • 4 CYL
  • TURBO
  • 2WD
  • AUTOMATIC
  • 170,000 MILES
So basically I was delivering pizzas, heater was working fine air was all fine, turned off my car came back outside heater wasn't working. I wasn't aware of where my blower motor was thought it may of froze up, so I let the car idle I also checked my fuse 13 see if it was blown fuse 13 is good. Me and my father took out the blower fan connected it to our battery charger it spun up. Checked wires, fine. Check resistor seemed fine. We don't know how to see if the resistor is broken. So far we bought a new fan and resistor on the way. We don't know what could be causing this issue because everything we tested seem fine. Power from the wire into resistor good, power out of resistor was there as well.
Do you
have the same problem?
Yes
No
Saturday, February 13th, 2021 AT 7:51 AM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good morning,

I posted the electrical diagram for you.

https://www.2carpros.com/articles/how-to-check-wiring

The most common issue is the resistor. You need to test fuse 11 for power to the resistor.

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Roy

Was this
answer
helpful?
Yes
No
Sunday, February 14th, 2021 AT 7:06 AM
Tiny
AUSTIN REED
  • MEMBER
So we took out the resistor and the blower around 7 times everything seemed to work we ended up punching the dash and everything seemed to start working again.
Was this
answer
helpful?
Yes
No
Monday, February 15th, 2021 AT 6:17 AM
Tiny
ASEMASTER6371
  • EXPERT
What was the voltage to the resistor?

Roy
Was this
answer
helpful?
Yes
No
Monday, February 15th, 2021 AT 10:06 AM

Please login or register to post a reply.

Sponsored links