Heater is not working

Tiny
MRPIZAL
  • MEMBER
  • 2008 CHRYSLER SEBRING
Heater problem 6 cyl Two Wheel Drive Automatic 15000 miles

The heater is not working. The lights don't light up on the climate control the blower works but it blows out cold air and the rear defrost doesn't come on? I love this site
Do you
have the same problem?
Yes
No
Wednesday, November 26th, 2008 AT 10:32 PM

4 Replies

Tiny
KEN
  • ADMIN
It sounds like you have two seperate problem let's address the heat issue which sounds like a temperature blend door actuator that is out and needs to be replaced. Here is a guide to help you see what i am talking about.

https://www.2carpros.com/articles/replace-blend-door-motor

and

https://www.2carpros.com/articles/car-heater-not-working

And here is where it is at on your car (below)

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, October 23rd, 2017 AT 3:52 PM
Tiny
BLUEKILLAK
  • MEMBER
  • 2010 CHRYSLER SEBRING
  • 0.6L
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 103,891 MILES
I got a new thermostat a new head gasket and a hose and my car is still blowing cold air. I know I have to get a transmission flush and a transmission pan do you think I need a heater core. Thank You.
Was this
answer
helpful?
Yes
No
Monday, October 23rd, 2017 AT 3:52 PM (Merged)
Tiny
HMAC300
  • EXPERT
Try pulling fuse 6 & 8 with key on for 60 seconds see if actuators reset. Tha tmay give you warm air. Make sure heater hoses are both hot. If that doesn't work have it scanned for codes. Auto parts cannot do that.
Was this
answer
helpful?
Yes
No
Monday, October 23rd, 2017 AT 3:52 PM (Merged)
Tiny
BLUEKILLAK
  • MEMBER
Ok thanks I thought it might have been the compressor.
Was this
answer
helpful?
Yes
No
Monday, October 23rd, 2017 AT 3:52 PM (Merged)

Please login or register to post a reply.

Recommended Guides