Cooling Fans Not Working

Tiny
SETLOCB
  • MEMBER
  • 2005 CHEVROLET VENTURE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 69,700 MILES
My cooling fans are not working. They do work when the A/C is on. I checked all fuses, they are ok. I changed the relay's and changed the coolant temp. Sensor. What else could the problem be?
Do you
have the same problem?
Yes
No
Friday, May 30th, 2008 AT 10:46 AM

3 Replies

Tiny
LEGITIMATE007
  • EXPERT
Thermostat may not be opening to let the coolant rush by the engine coolant temp sensor, try a new thremostat
Was this
answer
helpful?
Yes
No
Friday, May 30th, 2008 AT 2:28 PM
Tiny
SETLOCB
  • MEMBER
Thanks for answering my question. That's exactly what I just finished up with, changing the thermostat. No luck though. The fans still not working. There's not much left to check besides the PCM. Is there a way I can test that myself, or is that something I should have a garage check? Thanks again.
Was this
answer
helpful?
Yes
No
+2
Friday, May 30th, 2008 AT 8:16 PM
Tiny
LEGITIMATE007
  • EXPERT
So the fans still won't come on, even when the temp gauge reaches the red area? if this is the case then yeah have a garage check the pcm.

Read these guides, they will help you figure this out

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

https://www.2carpros.com/articles/how-to-check-wiring

The wiring diagram for your cooling fans is attached below
Was this
answer
helpful?
Yes
No
-1
Friday, May 30th, 2008 AT 11:07 PM

Please login or register to post a reply.

Sponsored links