1996 Chevy Truck Continues problems, No power, Hard starts

Tiny
JEFFHADLEY
  • MEMBER
  • 1996 CHEVROLET TRUCK
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 125,000 MILES
Ok well its a 96 chevy 1500 v6 4.3 with a rebuilt trans about 10k old. I have had several fuel pump problems replaced it abour 4 times, luckly autozone warrentee cover replacement, the last time I notice a slightly frayed wire in the fuel pump assembly, fixed it no problems for about a month, then it died again wasnt able to start at all, just try and turn over. On the side of road dropped tank again, installed new pump. Started right up. But only had about 75% power, cant go over 3000 rpms just act sluggish. Been getting worse only way its been working is b/c ive been babying it. Starting my truck has been getting worse over last couple of weeks. Yesterday it wouldn't crank at all. With key in ON pos, fuel pressure is 60 but wasnt holding more than few seconds, figured fuel pressure regulator was at fault replace it, same problem, finally started went to drive and same as before. Tomorrow gonna double check Crankshaft sensor. No check engine light, No power and hards starts have to (I think) relate to each other. BTW about six months ago I was having two codes cant remember them but they were both cat releated, I (being stupid) figured it was gonna have to be replace at some point and clogged cat could cause loss of power. Anyway I cut out the cat about a month ago after I notice loss of power thinking it was the culprit, straight piped it and all O2 sensors are plugged in. Sorry post so long, thanks for your time
Do you
have the same problem?
Yes
No
Sunday, January 10th, 2010 AT 10:15 PM

1 Reply

Tiny
JEFFHADLEY
  • MEMBER
Ok starting problem was because of worn distributor parts, not making good contact, sanding charded marks off and now it has no starting problem at all. Still got 75% power, cant go over 3000 rpms, Im throwing a P1810, I dropped pan and checked TFP switch visually extremely dirty with clutch material, cleaned with contact cleaner, dried reinstalled, reset codes, code came back? Any ideas?
Was this
answer
helpful?
Yes
No
Monday, January 11th, 2010 AT 7:32 PM

Please login or register to post a reply.

Recommended Guides