1995 Subn A/C Tranny electrical short

Tiny
DRIVERDEAN
  • MEMBER
  • 1995 CHEVROLET SUBURBAN
Have a 1995 Chevy Subn 1500 4WD with 350 engine and 188k on it. Seems like it lacks Amps and or Voltage to the (this is where I need help) causing the following to happen. Voltage gauge on dash tends to read low around 13 volts or lower-when I test at the battery I have 14.5. The transmission chatters and whines (esp. In the lower gears) until you get up to speed if you have the A/C on-if you turn it off the noise stops instantly. When you are in highest gear you can turn the A/C back on and it will work fine. Otherwise the truck runs great with plenty of power and normal shifting even when towing. I also think the truck cranks a bit slow like it has a weak battery but putting in a new optima did not change this. I'm a lifelong mechanic tricked on this one, looking for a GMC guy who has been there on this problem. Thanks
Do you
have the same problem?
Yes
No
Sunday, June 24th, 2007 AT 4:54 PM

1 Reply

Tiny
CHRIS_KOLAR
  • MEMBER
The starter may be going bad. I picked up a mini starter at a junk yard for 40 bucks. The chatters sound like loose converter bolts or fried converter. The converter bolts are a visual check, the tranny oil will tell you if your converter is fried-it will smell bad and heavily discolored-usually a shudder will give the converter failure away first. The whining could be the pump-variable vane-metal blades could be starved by a blocked filter, loose or improperly installed filter. A few ideas I hope this helps.
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2007 AT 12:00 AM

Please login or register to post a reply.

Sponsored links