A/C blowing warm even with full charge

Tiny
LILRIDDLES@ETV.NET
  • MEMBER
  • 2001 CHEVROLET SUBURBAN
  • V8
  • 4WD
  • AUTOMATIC
  • 153,123 MILES
My A/C is blowing warm/hot all the time. Blend door is working, 134a is at full charge, compressor is cycling and working properly. What more could it be? All and any help greatly welcome.

All confused.
Do you
have the same problem?
Yes
No
Thursday, September 16th, 2010 AT 11:49 AM

16 Replies

Tiny
MERLIN2021
  • EXPERT
It sounds like you have an AC compressor that is not working (bad internal seals) which will cause no pressure difference in the system making no cold air. But to be sure here is a guide to help you confirm the issue and change out the compressor:

https://www.2carpros.com/articles/car-air-conditioner-not-working-or-is-weak

and

https://www.2carpros.com/articles/replace-air-conditioner-compressor

Please let us know what happens.

Cheers
Was this
answer
helpful?
Yes
No
Thursday, September 16th, 2010 AT 2:38 PM
Tiny
RADHO1
  • MEMBER
Thank you so much for this post. I fixed the car myself and got the compressor from Amazon. I love this site.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:55 PM
Tiny
99MONGUSE
  • MEMBER
  • 2001 CHEVROLET SUBURBAN
  • V8
  • 4WD
  • AUTOMATIC
  • 98,000 MILES
A/C blows warm when not moving but cold when moving.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Check the air blend door and actuator.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
99MONGUSE
  • MEMBER
I come out of work on my lunch hour and start the truck to eat lunch with the A/C on, since it is hot outside. I start the truck, turn on A/C and sit and sit and sit with actually hot air coming from all vents. I can sit there for my entire lunch hour with no cold A/C but if I drive down the road for about five minutes at moving speed of fifteen or more mph, the A/C gets cold fast and is really cold (I had the system charged, the rear evaporator has a small leak but it holds pressure, it took almost two years to get to a point where the A/C would not blow cold anymore). When I feel it get cold I turn around and go park back at work, letting the truck idle while I eat it is plenty cold.
Was this
answer
helpful?
Yes
No
-2
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
HMAC300
  • EXPERT
Check for a vacuum leak or your fan not pulling enough air into the engine. When you are moving the movement gets enough air to cool the condenser where the heat goes from inside the car. You should never run A/C at idle anyhow due to higher pressure being built up, 1,500 rpm is more of a good speed for this. Sounds like you need more air movement across condenser to cool the unit. If you have an electric fan maybe one is not working when it should be. If you have electric fan there should be two an done should go no automatically when you turn the air on. However, idling in that kind of heat is no good for cooling.
Was this
answer
helpful?
Yes
No
-2
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
2CARPROS-ARCHIVES
  • MEMBER
  • 2001 CHEVROLET SUBURBAN
  • 160,000 MILES
Will only blow hot air, regardless of what the temperature is set at on the climate controls. Local mechanic has looked at it twice now, replacing an A/C line filter and also a belt that was missing. (?) Both times they added refrigerant; second time they added a dye but did not find any leaks, (thought it might be a very slow leak). Both times it seemed to work for a week or so, but then back to the same symptoms. Winter is approaching, so nice to have heat, but it there is no way to control how hot it gets. Even when the air is set to off, it blows hot air. On a tight budget and cannot afford ongoing $300.00 to $400.00 invoices. Appreciate your help! CC
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
Use your hot to cold adjustment for the change in temperature.

You need another shop to find the leak as this seems a bit inexperienced.

Roy
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
DANCHE
  • MEMBER
  • 2001 CHEVROLET SUBURBAN
  • V8
  • 4WD
  • AUTOMATIC
  • 180,000 MILES
AC fuse keeps blowing it starts to blow warm. After I then replace it and it works for a few minutes then blows fuse again.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
JDL
  • EXPERT
If it is 10 amp A/C fuse? Suspect, something wrong with compressor or wiring circuit.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
ANN FORD
  • MEMBER
  • 2002 CHEVROLET SUBURBAN
  • 2.5L
  • V8
  • RWD
  • AUTOMATIC
  • 150,000 MILES
The fan was blowing very low even on high. They replaced the relay switch. And replaced the cabin filter in the front. It has front and rear A/C. It worked for about a week. Now it just blows hot air. Do you think the rear cabin filter could be causing the problem because it was not replaced?
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
HMAC300
  • EXPERT
Try pulling HVAC fuse one with key on for sixty seconds then reinstall and see if it works the temperature actuator may be bad or need to be reset. If that does it then fine if not have a mechanic scan for codes it may be controller or even low on Freon or something like that. I am assuming A/C compressor works however.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:56 PM (Merged)
Tiny
FRIEDTATORS
  • MEMBER
  • 2002 CHEVROLET SUBURBAN
  • V8
  • 4WD
  • AUTOMATIC
  • 144,000 MILES
We are working on the SUV listed above wit a 5.4L engine. When the A/C is put on auto, or when you play wit the control the mode doors after awhile compressor will shut off, and compressor switch will flash, will loose the ground to the relay from the PCM. With scanner shows that switch is shut off. Replaced control head, all A/C components are new. Sometimes will work fine for days, then will go off and after about thirty minutes will work again.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:57 PM (Merged)
Tiny
DOCFIXIT
  • EXPERT
PCM grounds AC compressor so if ground is lost and low pressure switch has tested good then PCM is faulty.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:57 PM (Merged)
Tiny
FRIEDTATORS
  • MEMBER
Yeah, it has a new low pressure switch.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:57 PM (Merged)
Tiny
DOCFIXIT
  • EXPERT
When PCM got into control things got complicated and pricey
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 2:57 PM (Merged)

Please login or register to post a reply.

Recommended Guides