1991 Suburban stalls under load

Tiny
TIMJETS
  • MEMBER
  • 1991 CHEVROLET SUBURBAN
1991 3/4 ton 350, 134k new distributor(prev. Ownew) coil, alt, plugs, fuel filter. Always starts fine, runs a bit sluggish until warms up, no stalling. After driving 20-30 min and shifting to reverse to back up, always stalls, or if I leave in drive and turn wheel it stalls. Always starts right up again. If I let it sit a few minutes, no stalling even with load. Has mechanics stumped. Occasionally will miss(not stall)after driving for 45 min. Also, engine seems to run about 75% efficiency, occasionally will run amazing, only for a day or so. No trouble codes at all. Vacuum good, idle control valve, neutral switch good. Egr seems to work fine. Tranny completely rebuilt w/new sensors, had problem before tranny work also. Thanks, Tim
Do you
have the same problem?
Yes
No
Tuesday, March 13th, 2007 AT 11:44 AM

4 Replies

Tiny
LVM76
  • MEMBER
Have the same problem on backup or hard steering at a stop. Never could solve the problem. Although after I replaced plugs/cap/rotor things got better and it stalled less. Better airfilter was also part of the tuneup.

Fuel pressure might be the problem. As your car gets older fuel pressure will drop just enough so that extra load on your engine (turning the steering at a stop, or throwing it in reverse fast) will cause the fuel pressure to drop just enough to cause a stall.

Just a guess.
Was this
answer
helpful?
Yes
No
Sunday, March 18th, 2007 AT 7:22 PM
Tiny
TIMJETS
  • MEMBER
Ivm76: Thanks for your help, I am replacing vacuum hoses first(original 1991), will let you know :)
Was this
answer
helpful?
Yes
No
Tuesday, March 20th, 2007 AT 10:42 AM
Tiny
LVM76
  • MEMBER
Vaccum leaks would cause idle to increase. So I wouldn't think that tighnening up your vaccum system would help.

Just try removing a vaccum line. Like your MAP. You'll probably stall less at sealevel- but overall performance will suffer as barometric pressure changes.

Have a 1990 2500 4x4. It seems to stall the most on hot days or at high altitude. My bet is on the fuel pressure, most likely the fuel pump loosing its power. Havnt hooked up a fuel pressure meter yet. But will try it shortly and let you know.
Was this
answer
helpful?
Yes
No
Tuesday, March 20th, 2007 AT 9:04 PM
Tiny
RLIGHT
  • MEMBER
See if you have a vacuum leak at the base of your throttle body. You might need a new gasket.
Was this
answer
helpful?
Yes
No
Wednesday, April 11th, 2007 AT 10:01 PM

Please login or register to post a reply.

Recommended Guides