1999 Chevy Silverado STARTS AND STALLS NO Pulse

Tiny
KDOBBS
  • MEMBER
  • 1999 CHEVROLET SILVERADO
  • V8
  • 4WD
  • AUTOMATIC
  • 100,000 MILES
HI GUYS; STARTS FINE EVERY TIME BUT DIES AFTER 1 SECOND. NO CODES NO SECURITY LIGHT. FUEL PRESSURE HOLDS AT 57- 49. NEG INJECTOR PULSE CUTS OF AND KILLS ENGINE. IGNITION SPARK KEEPS ON IF YOU CONTINUE TO CRANK AFTER STALL. HOPE YOU CAN HELP! THANKS

updated 3-6-09
It's a 5.3 liter vortec with the fuel rail and regulator on the exterior.
THE INJECTOR PULSE IS QUITING AFTER START UP. WHAT WOULD CAUSE THIS? THERE ARE NO CODES COMING UP, NO SECURITY LIGHT EXCEPT WHEN THE DOOR IS OPEN. THE BATTERY LIGHT IS ON EVEN AFTER THE BRIEF START BUT THE VOLTS GUAGE READS 13+. THE FUEL PRESSURE IS 57 PSI AND DROPS TO 49, AFTER SHUT OFF IT JUMPS BACK UP TO 57. THE PASSLOCK VOLTAGE WIRES READ 10 VOLTS ON THE POS, 0 ON THE NEG AND 5.4 ON THE YELLOW. WITH IGNITION ON THE YELLOW READS 5.7 VOLTS. IS THAT THE PROBLEM?
Do you
have the same problem?
Yes
No
Monday, March 2nd, 2009 AT 12:22 PM

6 Replies

Tiny
RASMATAZ
  • MEMBER
What liter engine is this?
Was this
answer
helpful?
Yes
No
Monday, March 2nd, 2009 AT 12:30 PM
Tiny
RASMATAZ
  • MEMBER
Do you have power on one of the injector harness connector? If so check the injector's resistances if okay the problem is coming from the computer's ground drivers
Was this
answer
helpful?
Yes
No
Thursday, March 5th, 2009 AT 2:59 PM
Tiny
KDOBBS
  • MEMBER
Mike, I tested the leads for voltage and found continuous positive voltage on one contact on the connector when I ground to the frame even after the engine stalls but when I test the voltage to the other contact on the harness the current stops when the engine stalls (after 1 second of running) I was thinking I had a shorted injector that could be shutting down the computer but I disconnected each injector one at a time doing a test start each time and the engine started for 1 second and died same as before. I keep thinking it's a passlock key switch thing, are the readings I got in an acceptable range?
Thanks !
Kim Dobbs
Was this
answer
helpful?
Yes
No
Thursday, March 5th, 2009 AT 7:15 PM
Tiny
RASMATAZ
  • MEMBER
Sounds like the computer is not schronizing the injectors -use a noid light to check it-
Was this
answer
helpful?
Yes
No
Friday, March 6th, 2009 AT 10:16 PM
Tiny
KDOBBS
  • MEMBER
RAZMATAZ, AS I MENTIONED, THE POSITIVE LEAD ON THE INTECTOR HARNES THAT I CHECKED REMAINS 12 VOLTS AFTER THE ENGINE SHUTS DOWN HOWEVER THE NEGATIVE PULSE QUITS AT THAT POINT. DO YOU THINK THE NOID LIGHT WILL SHOW SOMETHING DIFFERENT? I WAS WONDERING IF YOU KNOW WHAT THE PASSLOCK WIRES ARE SUPPOSED TO READ VOLTS WISE? I'VE READ THE PASSLOCK2 FEATURE ON THIS AND MANY OTHER GM VEHICLES CAN BE TOTALLY DEFUNCT. THANKS FOR ANY HELP YOU CAN GIVE ME.
Was this
answer
helpful?
Yes
No
Sunday, March 8th, 2009 AT 1:39 PM
Tiny
RASMATAZ
  • MEMBER
I don't think were dealing with the passlock

If you hook up the noid lite and it doesn't flash-get the computer tested
Was this
answer
helpful?
Yes
No
Sunday, March 8th, 2009 AT 3:54 PM

Please login or register to post a reply.

Recommended Guides