1992 Chevy Silverado won't restart

Tiny
DONOVANMOORE
  • MEMBER
  • 1992 CHEVROLET SILVERADO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 190,564 MILES
Sometimes my engine will start but when put in gear it will die and won't restart until it sits for a while or you can pour some gas in the throttle body and it will start. It also cuts out when driving steady and sometimes it will die when stopping. Iac checks out and tps checks out.
thank you
don moore
Do you
have the same problem?
Yes
No
Friday, December 12th, 2008 AT 2:09 PM

13 Replies

Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure and comeback with the readings this is where we start-
Was this
answer
helpful?
Yes
No
Friday, December 12th, 2008 AT 2:20 PM
Tiny
DONOVANMOORE
  • MEMBER
Ok guys the fuel pressure is 11 pounds and the book says it should be between 9-13 pounds. Have replaced iac and tps. Any other thoughts on what problem would be?
Was this
answer
helpful?
Yes
No
Saturday, December 20th, 2008 AT 2:56 PM
Tiny
RASMATAZ
  • MEMBER
Are you getting spark and do you have injection pulses?
Was this
answer
helpful?
Yes
No
Saturday, December 20th, 2008 AT 3:00 PM
Tiny
DONOVANMOORE
  • MEMBER
Yes I have spark haven't been able to check to see if have fuel pulses. It has always died when i'm by myself and I just pour gas in tbi and it fires right up and it may go a few days before it does it again.
Thanks
Was this
answer
helpful?
Yes
No
Saturday, December 20th, 2008 AT 3:07 PM
Tiny
RASMATAZ
  • MEMBER
Next time it dies immediately look at the injectors if its spraying fuel in a cone shape while cranking it over-
Was this
answer
helpful?
Yes
No
Saturday, December 20th, 2008 AT 3:13 PM
Tiny
DONOVANMOORE
  • MEMBER
It may not be spraying if I have to pour gas in to get it started, but I will check the next time to see.
If it's not spraying do you have any idea of something else I could check? Thank you for your help this is driving me crazy.
Thanks again
Was this
answer
helpful?
Yes
No
Saturday, December 20th, 2008 AT 3:23 PM
Tiny
DONOVANMOORE
  • MEMBER
PLEASE HELP; I checked the injectors when the motor died and I am NOT getting any pulses when I try to restart. I can pour gas in the tbi and it will start.
Thank you
Was this
answer
helpful?
Yes
No
Monday, December 22nd, 2008 AT 1:27 PM
Tiny
RASMATAZ
  • MEMBER
Do you have power at the injectors harness connector if so and its not pulsing test the resistance of the injectors and also the computer ground drivers-
Was this
answer
helpful?
Yes
No
Monday, December 22nd, 2008 AT 1:48 PM
Tiny
DONOVANMOORE
  • MEMBER
I just replaced the map and it didn't help.
I will test the injectors and get back to you.
Please excuse my ignorance, but how do you test ecm driver ground?
Thank you for helping, maybe we can find the problem.
Was this
answer
helpful?
Yes
No
Monday, December 22nd, 2008 AT 3:49 PM
Tiny
DONOVANMOORE
  • MEMBER
Tested the injectors and am getting voltage to one wire on each side but could not get pulse on other wires.
Thanks
Was this
answer
helpful?
Yes
No
Monday, December 22nd, 2008 AT 11:53 PM
Tiny
RASMATAZ
  • MEMBER
Have the computer tested
Was this
answer
helpful?
Yes
No
Tuesday, December 23rd, 2008 AT 2:41 PM
Tiny
DONOVANMOORE
  • MEMBER
Thanks for answering; I went out today to crank it and it cranked up but when I put it in gear it died, so I replaced the egr solenoid valve and the ignition module and it cranked right up and drove perfectly!
Maybe the module was going bad, it was a little coroded and had been on the truck for 16 years, so maybe that did it. If that dosen't fix it I will have the computer tested. I will keep you informed and thank you very much for your help and have a Merry Christmas.
Was this
answer
helpful?
Yes
No
Tuesday, December 23rd, 2008 AT 4:16 PM
Tiny
RASMATAZ
  • MEMBER
You're most welcome and you have a nice and safe Christmas and a Happy New 2009
Was this
answer
helpful?
Yes
No
Tuesday, December 23rd, 2008 AT 5:00 PM

Please login or register to post a reply.

Recommended Guides