1993 CHEVY S-10 S10 STALLS WHEN DECELERATING

  • Tiny
  • FA5
  • 1993 CHEVROLET S-10

Engine Mechanical problem
1993 Chevy S-10 6 cyl Four Wheel Drive Manual 140000 miles

The truck will stall when decertating or wen the revs drop after reving it up a little. Will not start right back, takes a couple minutes. When it does start back it idles fine for atleast 10 minutes ten it will stall. What could it be?

Do you
have the same problem?
Yes
No
Tuesday, October 20th, 2009 AT 3:04 PM

7 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Check and test the idle air control valve and EGR valve and TPS/MAP sensors.

Was this
answer
helpful?
Yes
No
Tuesday, October 20th, 2009 AT 3:07 PM
  • Tiny
  • FA5
  • MEMBER

Checked the EGR valve seemed ok, also changed the map and still nothing, the check engine light isnt on.

Was this
answer
helpful?
Yes
No
Wednesday, October 21st, 2009 AT 2:07 PM
  • Tiny
  • Rasmataz
  • MEMBER

Time to verify the fuel pressure -use a fuel pressure gauge and check if its within specs-fuel pump could be getting weak

Was this
answer
helpful?
Yes
No
Wednesday, October 21st, 2009 AT 3:34 PM
  • Tiny
  • FA5
  • MEMBER

Well I went and rented a tool that reads codes and got 16 codes at first but now its not even reading, I got a code for the EGR, MAP sensor and some other solinoids. I really think its the EGR, in the service book it said if the egr is bad the truck will stall when decelerating or after it idles. My dad seems to think its the computer, ECM I guess.

Was this
answer
helpful?
Yes
No
Saturday, October 24th, 2009 AT 4:03 PM
  • Tiny
  • Rasmataz
  • MEMBER

Clean out the idle air control valve and test the TPS and MAP sensors and see what happens.

Was this
answer
helpful?
Yes
No
Saturday, October 24th, 2009 AT 4:07 PM
  • Tiny
  • FA5
  • MEMBER

Welll we replacd the EGR, Idle air control valve and the TPS was changed today. After the tps was installed it ran for the longest its ran for since it broke down. He was about to drive off so I put on the air cleaner dropped the hood, he then rev'd it up a lil and it died. I also just cleaned the airfilter. He had 2 extra MAP's but still nothing change. Could it be the uel pressure regulator? Also if the ECM was bad would it even start up? Runing out of cash, time and ideas. Thanks.

Was this
answer
helpful?
Yes
No
Sunday, November 8th, 2009 AT 5:41 PM
  • Tiny
  • TotalS10Guy
  • MEMBER

Check the knock sensor

Was this
answer
helpful?
Yes
No
Wednesday, December 2nd, 2009 AT 11:28 PM

Please login or register to post a reply.

Other Engine Stall Questions