1993 Chevy S-10 idles rough

Tiny
CARI365
  • MEMBER
  • 1993 CHEVROLET S-10
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 102,000 MILES
Hello, I have a 1993 chevy S10 blazer with 102,000 miles that idles very rough at a stand still, but under power runs okay. I have replaced the fuel injectors, replaced the oxygen sensor, cleaned the egr, cleaned the throttle body, cleaned the plantum, cleaned the idle air control (that was very dirty), checked the charcol canister for fuel in it, it was okay, check spark plug wires for arching they were fine, put blazer on a scanner and came up with a rich fuel code which was a 44. No engine light or codes other than rich fuel. You can also smell a strong fuel smell especially when you first start the blazer then it seems to clear up. Im stumped. Would greatly appritiate your advice on what you think could be the problem
Do you
have the same problem?
Yes
No
Thursday, October 14th, 2010 AT 11:03 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure and get back with the readings
Was this
answer
helpful?
Yes
No
Thursday, October 14th, 2010 AT 11:30 PM
Tiny
CARI365
  • MEMBER
Hi, Im not able to get the fuel pressure readings the guy who has the tester is in the hospital. Could the problem be the cataltic converter. It has a very strong fuel odor, I did have replace all the fuel injectors if that helps.
Was this
answer
helpful?
Yes
No
Friday, October 22nd, 2010 AT 11:03 PM
Tiny
RASMATAZ
  • MEMBER
Could be disconnect the exhaust pipe on the exhaust manifold and hang it aside and try it again and see if it goes
Was this
answer
helpful?
Yes
No
Friday, October 22nd, 2010 AT 11:53 PM

Please login or register to post a reply.

Recommended Guides