CHEVY CRUISE CONTROL CUTS IN AND OUT

2006 Chevrolet Impala

Tiny

John Ho10

October, 11, 2010 AT 10:57 AM

Electrical problem
2006 Chevy Impala 6 cyl Front Wheel Drive Automatic 95,000 miles

Cruise control cuts in and out. After non-diagnosis by local shop, I checked the fuses and relays in fuse box under hood. I found several were not seated all the way. I pushed all down to seat properly and cruise worked fine for months. Now have problem again, and I re-seated relays and fuses. But problem resumes.

Unfortunately, Chevy fuse box and owners manual DOES not identify cruise fuse or relay. Help!

FOUND 103 RELATED QUESTIONS

2 Answers

Tiny

mmprince4000

October, 13, 2010 AT 9:17 AM

Use an electronics cleaner and dielectric grease on fuses, this should solve problem.

Tiny

John Ho10

February, 9, 2011 AT 6:23 PM

In addition to the above symptoms, the RPM's would increase 200-300 without a corresponding increase in speed. This condition occured in or out of "cruise" mode and frequently when car was cold. Cold weather seemed to make it worse. However, at times, after a warm up the cruise worked fine.
Frustrated, I took car to my shop. They discovered that the wire harness connected to the trans speed control sensor had corroded. They replaced wire harness and speed sensor. Works fine now.

Hope this helps those who were looking to replace the brake light switch. Perform electrical diagnostics on the trans speed sensor connector first.

Please login or register to post a reply.

Cabin Air Filter Replacement