2000 Chevy Impala starts but does't stay running

Tiny
20IMPALA00
  • MEMBER
  • 2000 CHEVROLET IMPALA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 129,000 MILES
Thank you for the previous advise but, problem persist. I have replaced all three ignition coils, spark plugs, and plug wires. I will change the fuel filter and pcv valve next. Any advice on why car won't stay on for more than five minutes before shuts off.
Do you
have the same problem?
Yes
No
Tuesday, November 4th, 2008 AT 6:43 PM

4 Replies

Tiny
DENNYP
  • EXPERT
How long does it run before it shuts off? Has it been scanned for trouble codes?
Was this
answer
helpful?
Yes
No
-1
Tuesday, November 4th, 2008 AT 9:04 PM
Tiny
20IMPALA00
  • MEMBER
Put scanner to car but no codes pop up, stays running between 2 and 5 mins.
Was this
answer
helpful?
Yes
No
Wednesday, November 5th, 2008 AT 6:14 PM
Tiny
DENNYP
  • EXPERT
Watch the engine data on the scanner to see if the ckp signal drops out. Monitor the fuel pressure while the engine is running. Make sure any aftermarket accesories are disabled.
Was this
answer
helpful?
Yes
No
+1
Wednesday, November 5th, 2008 AT 8:23 PM
Tiny
20IMPALA00
  • MEMBER
Took out fuel filter and the fuel iside was real dirty, installed new filter. Now car starts but runs rough skanner code reads po172 :system too rich(bank 1), cheked under the hood and plug wire #1, 3, and #5 are real hot to the touch #3 more than others. How can I correct this problem?
Was this
answer
helpful?
Yes
No
Saturday, November 8th, 2008 AT 6:02 PM

Please login or register to post a reply.

Sponsored links