1996 Chevy Cheyenne windshield wiper problem

Tiny
YELLOW_JACKIT
  • MEMBER
  • 1996 CHEVROLET CHEYENNE
  • V8
  • 2WD
  • AUTOMATIC
  • 113,000 MILES
The windshield wipers
on my '96 Chevy Cheyenne are only working occasionally. Generally, they won't work right away when I start the car after it's been sitting overnight. Sometimes they will then work after 30 minutes of driving. I've also noticed that if it's only been parked for a few hours and then started, there's no problem with the wipers either.

I'm not sure if the problem is with the wiper control module or the wiper motor. When I turn the wiper controls, even though the wipers don't turn, I can hear the wiper motor turning. In fact, as I move through the range of wiper speeds, I can hear the motor changing speeds, but no wiper movement.
Do you
have the same problem?
Yes
No
Tuesday, January 26th, 2010 AT 10:07 AM

3 Replies

Tiny
RACEFAN966
  • EXPERT
Check the wiper arm to make sure it is tight to the wiper stud. If not then replace the wiper arm. Let me know what you find here and we will go from there. You may need a test light or digitlal multi meter to do some tests ok.
Was this
answer
helpful?
Yes
No
Tuesday, January 26th, 2010 AT 10:18 AM
Tiny
YELLOW_JACKIT
  • MEMBER
Thanks for the suggestion. I checked and mechanically, everything seems to be in working order. The wiper arms are both firmly affixed to the studs.

More details based on how things went on the drive home last night and drive in this morning. Last night, the wipers had no problems and worked as soon as I started up the car. Tested them once more when I got home and again they worked. Got up this morning to drive in, and the wipers wouldn't go. I tried a few more times during my drive. About 20 minutes into my drive, they finally started to work. I didn't do anything to make them work, just tried turning the wiper controls and they came on.
Was this
answer
helpful?
Yes
No
Wednesday, January 27th, 2010 AT 10:06 AM
Tiny
RACEFAN966
  • EXPERT
Ok if you have a digital multi meter then I need you to do a couple of tests ok. First the yellow wire at the wiper motor make sure there is constant power there. Turn the wiper switch to low and check for power at the brown wire. Then turn the wipers to high and check for power at the purple wire. Do this when the wipers are not working and let me know what you find ok. Thanks.
Was this
answer
helpful?
Yes
No
Wednesday, January 27th, 2010 AT 10:32 AM

Please login or register to post a reply.

Recommended Guides