1994 Chevy Cavalier Engine stalls

Tiny
DRAPTOR660R
  • MEMBER
  • 1994 CHEVROLET CAVALIER
  • 4 CYL
  • FWD
  • MANUAL
  • 178,000 MILES
My engine on my 94 2.2 liter 5 speed cavalier stalls only when the clutch is pressed in and only when the car is at normal operating temperature. I've replaced the idle control valve, map sensor, cleaned the throttle plate, and replaced a bad vacuum line. Nothing has fixed the problem. I was wondering if you guys had any ideas. Thanks
Do you
have the same problem?
Yes
No
Tuesday, April 22nd, 2008 AT 1:37 AM

5 Replies

Tiny
BMRFIXIT
  • EXPERT
Will it start back up or you have to wait on it

check for spark
check for fuel pressure
check crank sensor
check for vacuum leak s
Was this
answer
helpful?
Yes
No
Tuesday, April 22nd, 2008 AT 5:39 AM
Tiny
DRAPTOR660R
  • MEMBER
Yes it will start back fine. Sometimes the rpms falls real low and it recovers. It only happens when the engine is at operating temperature and it only happens when you are coming to a stop and you press the clutch into down shift or when the car is at operating temperature and the car can be parked in neutral and you press in the clutch and it does the same. The car never does it when the car is cold only at operating temperature. Thanks
Was this
answer
helpful?
Yes
No
Tuesday, April 22nd, 2008 AT 4:11 PM
Tiny
BMRFIXIT
  • EXPERT
Try to perform an idle relearn procedure
1- disconnect battery for 1min
2- restore battery power
3- make sure AC and all accessory off nothing on
4- apply e brakes
5- start engine place tranny in neutral allow engine to run until coolant fan has cycled once about 10 min maximum
6- turn engine and key off for at least 5 sec
7- and then repeat step 5
8- allow engine to run for at least 5 min
the correct IACV values for proper idle control will now be stored
Was this
answer
helpful?
Yes
No
Tuesday, April 22nd, 2008 AT 5:17 PM
Tiny
DRAPTOR660R
  • MEMBER
Would this problem really have anything to do with the IACV? Because the car idles fine the only time I have a problem is when the clutch is pressed in and the car is at normal operating temperature. I also replaced the IACV with a new one and that didnt fix it. I will try procedure in the mean time. Once I have tried it I will reply and let you know what happened.
Thanks
Was this
answer
helpful?
Yes
No
Tuesday, April 22nd, 2008 AT 10:06 PM
Tiny
DRAPTOR660R
  • MEMBER
I tried the procedure that you gave me and nothing. The problem is still there and still the same. Thanks
Was this
answer
helpful?
Yes
No
Wednesday, April 23rd, 2008 AT 2:18 AM

Please login or register to post a reply.

Recommended Guides