I am hearing a popping sound

Tiny
PMARTINEZ82
  • MEMBER
  • CHEVROLET CAMARO
Hi, I have a 1995 Chevy Camaro with a 3.4 v6 that has 201,000 miles, well I am hearing a popping noise coming from my engine when I start the engine, I opened up the hood and I could feel the popping coming from the ignition coil, and the popping is pretty loud, but after like 10 min or so the noise goes away, where do you think it could from?
Do you
have the same problem?
Yes
No
Friday, February 9th, 2007 AT 2:51 PM

4 Replies

Tiny
BRUCE HUNT
  • EXPERT
When was the transmission fluid level checked? When was is last replaced along with the internal filter? Was it replaced with generic fluid or Honda approved fluid?
Was this
answer
helpful?
Yes
No
Friday, February 9th, 2007 AT 3:12 PM
Tiny
DEVIN12M
  • MEMBER
I checked the tranny fluid level and it is fine. I bought the car about a month ago with this problem. Im not sure if this was oem honda fluid and im also not sure about the filture.
Was this
answer
helpful?
Yes
No
Saturday, February 10th, 2007 AT 3:42 AM
Tiny
DEVIN12M
  • MEMBER
Filter*
Was this
answer
helpful?
Yes
No
Saturday, February 10th, 2007 AT 3:44 AM
Tiny
DEVIN12M
  • MEMBER
Another note I should add. If I start the car in the morning or what not and it is cold, I start driving in "2" then shift to "S", which technicaly should be 3rd the tranny will shift from what I can feel to fourth, untill it is warm.
Was this
answer
helpful?
Yes
No
Saturday, February 10th, 2007 AT 3:47 AM

Please login or register to post a reply.

Sponsored links