1995 Chevy Camaro fuel delivery

Tiny
INKSLINGER_25
  • MEMBER
  • 1995 CHEVROLET CAMARO
Engine Mechanical problem
1995 Chevy Camaro 6 cyl Two Wheel Drive Automatic

the car will start if you prime the intake with a mist of gas and then continue to run fine.I noticed I didnt hear the fuel pump running when I turn the key. It seems as if the engine isnt being primed for startup automatically
Do you
have the same problem?
Yes
No
Tuesday, September 7th, 2010 AT 7:54 PM

17 Replies

Tiny
WRENCHTECH
  • EXPERT
You can find out if you use a fuel pressure gauge.
Find out if it primes, what the pressure is and what the pressure does when shut off.
Was this
answer
helpful?
Yes
No
Tuesday, September 7th, 2010 AT 8:04 PM
Tiny
INKSLINGER_25
  • MEMBER
If this is the case that it isnt getting the recommended 41 to 47psi at the fuel rails then what would be the possible resolution. Could it be a faulty relay?
Was this
answer
helpful?
Yes
No
Tuesday, September 7th, 2010 AT 8:12 PM
Tiny
WRENCHTECH
  • EXPERT
Run the tests and give me the results
Was this
answer
helpful?
Yes
No
Tuesday, September 7th, 2010 AT 8:13 PM
Tiny
INKSLINGER_25
  • MEMBER
I checked the fuel pressure and it was in the recommended range of 41 to 47 but it fell off when I cranked the engine but didnt leak off pressure.I replaced the fuel pump and the fulter but it still has the same problem it had before. What could it be now?
Was this
answer
helpful?
Yes
No
Friday, September 17th, 2010 AT 1:56 AM
Tiny
WRENCHTECH
  • EXPERT
Does the engine have spark?
Will it run temporarily if you prime the intake with starting fluid or carb cleaner?
Was this
answer
helpful?
Yes
No
Friday, September 17th, 2010 AT 4:16 AM
Tiny
INKSLINGER_25
  • MEMBER
Well I do not have starting fluid but it does run when you spray gas in the intake. Last time I started it like that I drove it about 3 miles to see how it ran. Why would it not start but continue to run if you prime it to start it?
Was this
answer
helpful?
Yes
No
Friday, September 17th, 2010 AT 2:31 PM
Tiny
WRENCHTECH
  • EXPERT
That's usually a fuel pressure issue. It's possible the relay could be bad and it's getting power from the oil pressure switch once the oil pressure builds up. You need to use a fuel pressure gauge to see if it primes to spec when the key is turned on.
Was this
answer
helpful?
Yes
No
Friday, September 17th, 2010 AT 2:40 PM
Tiny
INKSLINGER_25
  • MEMBER
The pump kicks on when I turn the key on and just as the engine trys to run it will just die. What could make it not start unless its primed but then let it run fine once its running with no engine light or anything on. If the relay is bad the pump would never come on would it?/
Was this
answer
helpful?
Yes
No
Saturday, September 18th, 2010 AT 12:27 AM
Tiny
INKSLINGER_25
  • MEMBER
Could the factory security system possibly make the engine not start but be able to run if you prlime it to start?Im running out of ideas!Please help!
Was this
answer
helpful?
Yes
No
Saturday, September 18th, 2010 AT 12:43 AM
Tiny
WRENCHTECH
  • EXPERT
No, it's not possible. You have Passkey and the Passkey system locks out the starter.
You just need to systematically test the circuit using a fuel pressure gauge and test light. And see what is causing it to shut off
Was this
answer
helpful?
Yes
No
Saturday, September 18th, 2010 AT 6:18 AM
Tiny
INKSLINGER_25
  • MEMBER
Ok now I think I have tripped the security system because the guages will work and stuff but when I turn the key the starter wont do anything but the fuel pump and everything else still works as normal so how do I reset it so it will crank and I can get back to troubleshooting the original problem
Was this
answer
helpful?
Yes
No
Saturday, September 18th, 2010 AT 2:19 PM
Tiny
WRENCHTECH
  • EXPERT
There is nothing to reset. Until the module see the correct resistance in the key, it's not going to unlock. At this point we don't even know if the key sensor was the original problem or not.
Was this
answer
helpful?
Yes
No
Saturday, September 18th, 2010 AT 2:33 PM
Tiny
INKSLINGER_25
  • MEMBER
Is there a simple way to do away with the security system and will the local dealer disable it for me so I dont have to pay 700 for the "brain" or will the be stuck on selling me the parts. Do I need to look for a smaller reputable garage if im looking to just have it disabled?
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 3:11 PM
Tiny
WRENCHTECH
  • EXPERT
No, the security system cannot be disabled for any price. It HAS to be working.
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 3:14 PM
Tiny
INKSLINGER_25
  • MEMBER
Ok I got it where it would crank again but it still does not start. When I plugged a cd player I had bought for the car it started working fine again. Still acts as if it is not getting gas. Im gonna check the vacume line to the fuel pressure regulator to see if its gooked up and working properly
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 11:49 PM
Tiny
INKSLINGER_25
  • MEMBER
Thanks for all your help and I just dont want anyone else stuck with this very confusing problem. It turned out to be the key switch. The connections for the resistor were worn and would make contact for it to start then when u let the pressure off the key it would lose connection causing the injectors to shut down. Thats why it seemed the fuel pump was bad. My parts and labor still only costed $135 so to me it was a cheap fix. Thanks again and if I ever have another problem this is where I will come because this is the most solid info ive ever got from a forum
Was this
answer
helpful?
Yes
No
Thursday, September 23rd, 2010 AT 11:20 AM
Tiny
WRENCHTECH
  • EXPERT
Your welcome.

Using the feedback link is always appreciated.
Was this
answer
helpful?
Yes
No
Thursday, September 23rd, 2010 AT 11:23 AM

Please login or register to post a reply.

Recommended Guides